<!DOCTYPE html>
<html lang="en" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

<head  prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">

	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

	

	<link rel="shortcut icon" href="http://cdn7.digitaltrends.com/favicon.ico?ver=2" />
	<link rel="apple-touch-icon" href="http://cdn7.digitaltrends.com/touch-icon-iphone.png?ver=2" />
	<link rel="apple-touch-icon" sizes="72x72" href="http://cdn7.digitaltrends.com/touch-icon-ipad.png?ver=2" />
	<link rel="apple-touch-icon" sizes="114x114" href="http://cdn7.digitaltrends.com/touch-icon-iphone4.png?ver=2" />

	<style>
		@-ms-viewport {
		    width: extend-to-zoom;
		    zoom: 1.0;
		}
	</style>
	<meta name="viewport" content="initial-scale=1" />

	
					<meta name="tags" content="AMD,RADEON,Radeon Software Crimson ReLive Edition,Warhammer 40000 Dawn of War III" />
				
		<script>
			(function() {
				var query_string, query_vars, utm_source, utm_medium, utm_term, utm_content, utm_campaign, i, l, keyval, utm_cookie;

				// check query
				query_string = window.location.search.substring(1);
				query_vars   = query_string.split('&');

				utm_source = utm_medium = utm_term = utm_content = utm_campaign = '';
				for (i = 0, l = query_vars.length; i < l; i++) {
					keyval = query_vars[i].split('=');

					if (undefined !== keyval[0] && undefined !== keyval[1]) {
						if ('utm_source' === keyval[0]) {
							utm_source = keyval[1];
						}
						else if ('utm_medium' === keyval[0]) {
							utm_medium = keyval[1];
						}
						else if ('utm_term' === keyval[0]) {
							utm_term = keyval[1];
						}
						else if ('utm_content' === keyval[0]) {
							utm_content = keyval[1];
						}
						else if ('utm_campaign' === keyval[0]) {
							utm_campaign = keyval[1];
						}
					}
				}

				if (utm_source || utm_medium || utm_term || utm_content || utm_campaign) { // try for new
					window.dt_utm_data = {
						utm_source:   utm_source,
						utm_medium:   utm_medium,
						utm_term:     utm_term,
						utm_content:  utm_content,
						utm_campaign: utm_campaign
					};

					document.cookie = 'dt_utm='+JSON.stringify(window.dt_utm_data)+'; expires=0; path=/';
				}
				else { // try for old
					utm_cookie = (result = new RegExp('(?:^|; )'+encodeURIComponent('dt_utm')+'=([^;]*)').exec(document.cookie)) ? (result[1]) : null;

					if (utm_cookie) {
						window.dt_utm_data = JSON.parse(utm_cookie);
					}
				}
			})();
		</script>

		
<!-- This site is optimized with the Yoast SEO plugin v4.6 - https://yoast.com/wordpress/plugins/seo/ -->
<title>AMD Radeon Crimson ReLive Edition 17.4.4 Adds Support for &#039;Dawn of War III&#039; | Digital Trends</title>
<meta name="description" content="AMD&#039;s latest offering of Radeon Crimson ReLive Edition drivers adds support for Warhammer 40,000: Dawn of War III."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217;" />
<meta property="og:description" content="AMD&#039;s latest offering of Radeon Crimson ReLive Edition drivers adds support for Warhammer 40,000: Dawn of War III." />
<meta property="og:url" content="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/" />
<meta property="og:site_name" content="Digital Trends" />
<meta property="article:publisher" content="https://www.facebook.com/digitaltrends" />
<meta property="article:author" content="https://www.facebook.com/bradjonze" />
<meta property="article:tag" content="AMD" />
<meta property="article:tag" content="RADEON" />
<meta property="article:tag" content="Radeon Software Crimson ReLive Edition" />
<meta property="article:tag" content="Warhammer 40000 Dawn of War III" />
<meta property="article:published_time" content="2017-04-27T10:07:11-07:00" />
<meta property="og:image" content="http://icdn2.digitaltrends.com/image/radeon-rx-570-offset1sf-1200x630-c.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="AMD&#039;s latest offering of Radeon Crimson ReLive Edition drivers adds support for Warhammer 40,000: Dawn of War III." />
<meta name="twitter:title" content="AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217;" />
<meta name="twitter:site" content="@digitaltrends" />
<meta name="twitter:image" content="http://icdn3.digitaltrends.com/image/radeon-rx-570-offset1sf-510x0.jpg" />
<meta name="twitter:creator" content="@beardjones" />
<!-- / Yoast SEO plugin. -->

		<link rel="amphtml" href="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/amp/">
		<link rel='dns-prefetch' href='//content.jwplatform.com' />
<link rel='dns-prefetch' href='//secure-dcr.imrworldwide.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Digital Trends | Feed" href="http://www.digitaltrends.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Digital Trends | AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217; Comments Feed" href="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/feed/" />
<link rel='stylesheet' id='dashicons-css'  href='http://cdn6.digitaltrends.com/wp-includes/css/dashicons.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='admin-bar-css'  href='http://cdn4.digitaltrends.com/wp-includes/css/admin-bar.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='dt-css'  href='http://cdn5.digitaltrends.com/wp-content/themes/digitaltrends-2014/assets/styles/css/dt.css?ver=1493051905961' type='text/css' media='all' />
<script type='text/javascript' src='http://cdn1.digitaltrends.com/bower_components/jquery/jquery.js?ver=1.8.3'></script>
<script type='text/javascript' src='http://secure-dcr.imrworldwide.com/novms/js/2/ggcmb500.js?ver=1493051905961'></script>
<script type='text/javascript' src='http://cdn2.digitaltrends.com/wp-content/themes/digitaltrends-2014/assets/scripts/js/dt-head.min.js?ver=1493051905961'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.digitaltrends.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.digitaltrends.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://www.digitaltrends.com/?p=1171292' />
<meta name="news_keywords" content="radeon, amd, crimson relive edition, dawn of war"><meta name="framework" content="Alkivia Framework 0.8" />

			<!-- Begin GPT -->
			<script type="text/javascript">
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
					var gads   = document.createElement( 'script' );
					gads.async = true;
					gads.type  = 'text/javascript';
					var useSSL = 'https:' == document.location.protocol;
					gads.src   = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
					var node   = document.getElementsByTagName( 'script' )[0];
					node.parentNode.insertBefore( gads, node );
				})();
			</script>
			<!-- End GPT -->

			

<!-- BEGIN Sailthru Horizon Meta Information -->
<meta name="sailthru.date" content="2017-04-27 10:07:11" />
<meta name="sailthru.title" content="AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217;" />
<meta name="sailthru.tags" content="AMD, RADEON, Brad Jones, Computing, Gaming" />
<meta name="sailthru.author" content="Brad Jones" />
<meta name="sailthru.description" content="The latest set of Radeon Crimson ReLive Edition drivers from AMD introduces support for Warhammer 40,000: Dawn of War, alongside a host of fixes to known issues and other nagging bugs." />
<meta name="sailthru.image.full" content="http://icdn2.digitaltrends.com/image/radeon-rx-570-offset1sf-1500x1000.jpg" />
<meta name="sailthru.image.thumb" content="http://icdn3.digitaltrends.com/image/radeon-rx-570-offset1sf-50x50.jpg" />
<meta name="sailthru.image.ratio_3_2" content="http://icdn4.digitaltrends.com/image/radeon-rx-570-offset1sf-600x400-c.jpg" />
<meta name="sailthru.image.ratio_4_3" content="http://icdn5.digitaltrends.com/image/radeon-rx-570-offset1sf-480x360-c.jpg" />
<!-- END Sailthru Horizon Meta Information -->

		<!-- DT Variables (digitaltrends-2013/functions.php) -->
		<script type="text/javascript">
			var ajaxurl = "http://www.digitaltrends.com/wp-content/themes/digitaltrends-2014/ajax-actions.php";
			var ord 	= Math.random()*10000000000000000;
					var DT_Facebook_AppId = '61377565444';
		var DT_Facebook_ChannelUrl = 'http://www.digitaltrends.com/fb-channel.php';
		var DT_Facebook_PageId = '8522591132';
		
		window.dt_lists_map = {"dt-newsletter":"DT Newsletter","dt-deals-newsletter":"DT Deals Newsletter"};

				var DTVFeaturedVideoCategories = [{"query":"auto:recommended","title":"Trending Now"},{"query":"taxonomy:video_category:how-to-videos","title":"Quick Tips"},{"query":"taxonomy:video_category:car-videos,computer-videos,cool-tech-videos,home-videos,home-theater-videos,mobile-videos,outdoor-videos,photography-videos","title":"Latest Reviews"},{"query":"taxonomy:video_category:game-trailers","title":"Game Trailers"},{"query":"taxonomy:video_category:movie-trailers-videos","title":"Movie Trailers"},{"query":"taxonomy:video_category:home-theater-videos","title":"Home Theater"},{"query":"taxonomy:video_category:car-videos","title":"Cars"},{"query":"taxonomy:video_category:mobile-videos","title":"Mobile"},{"query":"taxonomy:video_category:computer-videos","title":"Computing"},{"query":"taxonomy:video_category:cool-tech-videos","title":"Cool Tech"},{"query":"taxonomy:video_category:how-to-videos","title":"How To"},{"query":"taxonomy:video_category:gaming-videos","title":"Gaming"},{"query":"taxonomy:video_category:home-videos","title":"Home"}];
				</script>
		<!-- End DT Variables -->
	
			<script>
				(function() {
					'use strict';

					var l10ns = {"ahe084RE8hgWerv8":{"site-head":{"back_to_menu":"Back to Menu","current_article":"Now Reading","digital_trends":"Digital Trends","menu":"Menu","popular_categories":"Popular Categories","search":"Search","search_phrase":"What can we help you find?","share":"Share","shop_cta":"Buy Now"}}};

					var get = function get(key, group) {
						key = key || '';
						group = group || 'ahe084RE8hgWerv8';

						if (typeof l10ns[group] !== 'undefined') {
							if (key && typeof l10ns[group][key] !== 'undefined') {
								return l10ns[group][key];
							}
						}

						return null;
					};

					window.DTL10n = {
						get: get,
					};
				}());
			</script>

			
			<script>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</script>

																						<link rel="alternate" hreflang="x-default" href="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/" />
																											<meta property="fb:app_id" content="61377565444"/>
		<meta property="fb:pages" content="8522591132" /><style type="text/css" media="print">#wpadminbar { display:none; }</style>
		<script>
		function onJWPlayerEvent( event, player, event_args ){
			DTEvent.trigger( 'jwplayer:' + event, player, event_args );
		}
		</script>
				<script>

			DTEvent.on('jwplayer:onFirstFrame', function(_player) {

				var container_id = _player.id;

				//Do not track views for sticky related video
				if ( container_id != 'dt-sticky-video-container' ){
					var item = _player.getPlaylistItem(_player.getPlaylistIndex());

					if(item) {
						var req = $.ajax({
							url: ajaxurl + '?action=dt_video_view_tracker_ajax',
							cache: false,
							type: 'POST',
							data: {
								media_id: item.mediaid,
								provider: 'jwplayer'
							}
						}).done(function(res){

							if (res.status == 'OK' ){
								DT.Logger.log(res.message);

							}
							if (res.status == 'ERROR') {
								DT.Logger.log(res.message);
							}

						})
						.fail(function() {
							DT.Logger.log('DTV: Tracking request failed');
						});
					}
					else {
						DT.Logger.log('DTV: No attachment id to track.');
					}

				}

			});

		</script>
		<script>window.dtv_jwplayer_advertising = {client: "googima", tag: "http://pubads.g.doubleclick.net/gampad/ads?sz=970x556&iu=/5611/dtmn.video/dt_ros&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast3&unviewed_position_start=1&url=__page-url__&description_url=http%3A%2F%2Fwww.digitaltrends.com&correlator=__random-number__&cmsid=2860&vid=__item-mediaid__&cust_params=tags%3Damd%2Cradeon%2Cradeon-software-crimson-relive-edition%2Cwarhammer-40000-dawn-of-war-iii%26cat%3Dcomputing%2Cgaming%2Ctrending%26supports%3Dbt%2Cmp%2Cskin%26aid%3D1171292", schedule: '', admessage: '', companiondiv: [], skipoffset: null};</script>		<script>
			window.dataLayer = [{
															'ajax_url': 'http://www.digitaltrends.com/wp-content/themes/digitaltrends-2014/ajax-actions.php',
																				'canonical_url': 'http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/',
																				'post_id': '1171292',
																				'post_title': 'AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217;',
																				'page_type': 'single',
																				'post_type': 'post',
																				'post_author': 'Brad Jones',
																				'publish_date': '1493251200',
																				'publish_date_by_day': '20170427',
																				'word_count': '334',
																				'header_media_type': 'image',
																				'category': ['computing','gaming'],
																				'post_tag': ['amd','radeon','radeon-software-crimson-relive-edition','warhammer-40000-dawn-of-war-iii'],
																				'post_format': [''],
																				'primary_category': 'gaming',
																				'primary_category_name': 'Gaming',
																				'primary_category_url': 'http://www.digitaltrends.com/gaming/',
																				'categories': 'computing,gaming',
																				'article_type': 'news',
												}];

			(function() {
				'use strict';

				if (window.DTPersonas) {
					var persona = window.DTPersonas.get();

					if (persona && window.dataLayer.length) {
						window.dataLayer[0]['persona'] = persona;
					}
				}
			}());

			(function() {
				'use strict';

				if (window.sessionStorage) {
					var id = window.sessionStorage.getItem('dtSessionId');

					if (!id) {
						id = (function() {
							var a = Date.now();
							var b = Math.floor((1 + Math.random()) * 0x100000).toString(16);
							var c = Math.floor((1 + Math.random()) * 0x100000).toString(16);

							return 'v1-'+a+'-'+b+'-'+c;
						}());

						window.sessionStorage.setItem('dtSessionId', id);
					}

					if (window.dataLayer.length) {
						window.dataLayer[0]['dt_session_id'] = id;
					}
				}
			}());
		</script>
		
		<script>
			if (window.dataLayer && window.dt_utm_data) {
				dataLayer.push(dt_utm_data);
			}
		</script>

		
</head>


<!--[if lt IE 7]> <body class="ie6 ie ieold post-template-default single single-post postid-1171292 single-format-standard dtads-unskin dtads-no-broadside"> <![endif]-->
<!--[if IE 7]>    <body class="ie7 ie ieold post-template-default single single-post postid-1171292 single-format-standard dtads-unskin dtads-no-broadside"> <![endif]-->
<!--[if IE 8]>    <body class="ie8 ie ieold post-template-default single single-post postid-1171292 single-format-standard dtads-unskin dtads-no-broadside"> <![endif]-->
<!--[if IE 9]>    <body class="ie9 ie post-template-default single single-post postid-1171292 single-format-standard dtads-unskin dtads-no-broadside"> <![endif]-->
<!--[if gt IE 9]><!-->
<body class="post-template-default single single-post postid-1171292 single-format-standard dtads-unskin dtads-no-broadside"  data-post-id="1171292" data-post-type="post" data-primary-category="6" >
<!--<![endif]-->

			<!-- Google Tag Manager -->
		<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WKFXF7"
		height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-WKFXF7');</script>
		<!-- End Google Tag Manager -->

		



<header class="m-bartender h-bartender" data-scope="bartender">

	<!--googleoff: all-->

		<span class="m-bartender--door h-front"></span>

		<span class="m-bartender--door h-back"></span>

	<!--googleon: all-->

	<section id="dt-site-head" class="m-site-head m-pint h-pint" data-type="fixed" data-essential="1">
		<div class="m-site-head--inner">
			<div class="m-site-head--brand">
				<a href="http://www.digitaltrends.com">
					<span class="label">Digital Trends</span>
				</a>
			</div>
		</div>
	</section>

</header>


<script type="text/template" id="t-paragon-alpha">
	<div class="m-pint h-pint" data-type="static">
		<div class="dt-paragon-3941d78430 alpha">
			<div class="inner">
				<div class="content">
					<div class="line a">
						Enjoy this <strong>ad free</strong> visit to<br>
						Digital Trends, courtesy of...
					</div>
					<div class="line b"></div>
				</div>

				<div class="continue">
					<div class="line a">Scroll to continue</div>
					<div class="line b">Enjoy</div>
				</div>

				<div class="overlay">
					What is this <span>?</span>
				</div>
			</div>
		</div>
	</div>
</script>


<script type="text/template" id="t-paragon-beta">
	<div class="m-pint h-pint" data-type="static">
		<div class="dt-paragon-3941d78430 beta">
			<div class="inner">
				<div class="content">
					<div class="line a">
						<strong>No&nbsp;Ads</strong>, <strong>No&nbsp;Interruptions.</strong> Courtesy&nbsp;of...
					</div>

					<div class="line b"></div>
				</div>

				<div class="overlay">
					What is this <span>?</span>
				</div>
			</div>
		</div>
	</div>
</script>


<script type="text/template" id="t-paragon-overlay">
	<div class="dt-paragon_overlay-3941d78430">
		<p>We noticed you are using an <strong>ad blocker</strong>. We understand that you may have many reasons for blocking our advertisers. At the same time, we need to keep the lights on here, so we can keep bringing you great content. This promotional consideration by <strong>Microsoft</strong> allows us to avoid tactics that we aren't totally comfortable with, like blocking our content.</p>

		<p>Here are some other ways you can <strong>support</strong> Digital&nbsp;Trends <strong>without disabling your ad blocker</strong>:</p>

		<ul>
			<li>Patronize the <a href="https://shop.digitaltrends.com/" target="_blank" rel="nofollow">DT Shop</a>.</li>
			<li>Visit our <a href="http://www.digitaltrends.com/deals/" target="_blank">Deals</a> page.</li>
			<li>Share our content on your <a href="https://www.facebook.com/DigitalTrends" target="_blank" rel="nofollow">favorite</a> <a href="https://twitter.com/digitaltrends" target="_blank" rel="nofollow">social</a> <a href="https://www.instagram.com/digitaltrends/" target="_blank" rel="nofollow">network</a>.</li>
			<li>Use <a href="https://www.google.com/contributor/welcome/" target="_blank" rel="nofollow">Google Contributer</a> to see less ads.</li>
		</ul>

		<p>Enjoy your <strong>ad free</strong> visit to Digital&nbsp;Trends without further interruption. Thanks!</p>
	</div>
</script>


<script>
	window.dt_paragon = '3941d78430';
</script>


<div class="l-main-container">

<div class="l-page "  data-dtads-inject="1" data-trending="1"itemscope itemtype="http://schema.org/Article" data-post-id="1171292" data-post-url="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/">

    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://google.com/article"/>

	
<div class="m-leaderboard ">
	<div class="l-block">
		<div class="dtads-slot dtads-slot-leaderboard dtads-desktop" data-type="leaderboard" ></div>		<div class="dtads-slot dtads-slot-leaderboard-tablet dtads-tablet" data-type="leaderboard_tablet" ></div>		<div class="dtads-slot dtads-slot-leaderboard-mobile dtads-mobile" data-type="leaderboard_mobile" ></div>
					<div class="dtads-slot dtads-out-of-page dtads-desktop dtads-tablet dtads-mobile" data-type="out_of_page" ></div>			</div>
</div>

	

	<div class="l-block  ">

		
			<header class="m-title-block">

				<div class="crumbs" data-scope="breadcrumbs">
					<span xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a href="http://www.digitaltrends.com/" rel="v:url" property="v:title">Home</a> <em>&gt;</em> <span rel="v:child" typeof="v:Breadcrumb"><a href="http://www.digitaltrends.com/gaming/" rel="v:url" property="v:title">Gaming</a> <em>&gt;</em> <span class="breadcrumb_last">AMD Radeon Crimson ReLive Edition 17.4.4 adds&hellip;</span></span></span></span>				</div>

				<h1 class="title" itemprop="headline">
					AMD Radeon Crimson ReLive Edition 17.4.4 adds support for &#8216;Dawn of War III&#8217;				</h1>

				
				<div class="byline">
					<cite data-scope="byline">
	<span class="by">By</span>

	
		<span class="vcard">
			<a class="author url fn " rel="author" href="http://www.digitaltrends.com/users/bradjones/" itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name">Brad Jones</span></a><!--This <a> here is good feng-shui -->
		</span>

		
	
	<span class="dash">&mdash;</span>

	<span itemprop="datePublished" content="2017-04-27 10:07 AM" class="date dtreviewed">
		<span class="value-title" title="2017-04-27 10:07 AM">
			<time datetime="2017-04-27T10:07:11+00:00 10:07 AM" pubdate="pubdate">
			    April 27, 2017 10:07 AM            </time>
		</span>
	</span>

	
	</cite>				</div>

			</header>

		
		
	

	<div class="m-header-media image" data-scope="header-media">
					
	<div class="m-share m-share_bar  full h-share-bar">
		<div class="m-share--wrap">

			<div class="key-items">

															<div class="key-item comment is-empty h-share-count h-show-comments">
							<a href="#comments-1171292">
								<span id="dt-dc-share-count-0" class="count h-count"></span>							</a>
						</div>
									

									<div class="key-item facebook is-empty h-share-count h-do-share" data-app="facebook">
						<a href="javascript:void(0)" title="Share this on Facebook">
							<span id="dt-dc-share-count-1" class="count h-count"></span>						</a>
					</div>
				

									<div class="key-item twitter is-empty h-do-share" data-app="twitter">
						<a href="javascript:void(0)" title="Share this on Twitter">
						</a>
					</div>
				

				
											<div class="key-item text subscribe is-empty h-topic-newsletter-subscribe">
							<a href="javascript:void(0)" title="Subscribe to this topic">
								<span class="text">Subscribe</span>
							</a>
						</div>
					
				

									<div class="key-item text share is-empty h-do-share">
						<a href="javascript:void(0)" title="Share this">
							<span class="text">Share</span>
						</a>
					</div>
				
			</div>

		</div>
	</div>

		
					
                <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">

                    <a href="http://s3.amazonaws.com/digitaltrends-uploads-prod/2017/04/Radeon-RX-570-offset1SF.jpg" rel="post">
                        <img width="640" src="http://icdn7.digitaltrends.com/image/radeon-rx-570-offset1sf-640x0.jpg" class="attachment-dt_header_media size-dt_header_media wp-image-1165914" alt="radeon crimson relive  rx offset sf" />                    </a>

                    <meta itemprop="url" content="http://s3.amazonaws.com/digitaltrends-uploads-prod/2017/04/Radeon-RX-570-offset1SF.jpg">
                    <meta itemprop="width" content="640">
                    <meta itemprop="height" content="360">

                </div>

				
				<div class='m-image-credit' data-image-id='1165914' >Bill Roberson/Digital Trends</div>
					
		
	</div>


	

		<aside class="l-sidebar h-smart-sidebar" data-uid="1171292" data-scope="sidebar">

	<div class="dtads-slot dtads-slot-half-roadblock dtads-desktop" data-type="halfpage_roadblock" ></div>

	

<div class="m-newsletter-widget  h-register-newsletter">

	<div class="line-1">Don't Fall Behind</div>

	<div class="line-2">Stay current with a recap of today's <strong>Tech News</strong> from <em>Digital&nbsp;Trends</em></div>


	<div class="message h-message"></div>


	<form class="h-form" method="post">
		<input type="text" class="field h-field" name="dt_newsletter_register_email" placeholder="Enter your email">

		<input type="hidden" name="dt_newsletter_source" value="dt-newsletter-widget">
		<input type="hidden" name="dt_lists[]" value="DT Newsletter">

		<input type="text" name="robot" value="" style="display:none">

		<input type="submit" class="submit h-submit" value="Sign Up">
	</form>

</div>


	<div class="l-group">
		<div class="dtads-slot dtads-slot-mpu-sticky dtads-desktop" data-type="mpu_sticky" ></div>	</div>

</aside>


<script type="text/template" id="t-discovery">
	<div class="m-discovery" data-scope="sidebar-discovery">
		<div class="items">
			<%= items %>
		</div>
	</div>
</script>


<script type="text/template" id="t-discovery-item">
	<div class="item <%- classes %>">
		<% if ( thumb ) { %>
			<div class="thumb">
				<a href="<%- permalink %>">
					<img src="<%- thumb %>" alt="" />
				</a>
			</div>
		<% } %>

		<div class="meta">
			<div class="title">
				<a href="<%- permalink %>">
					<%= title %>
				</a>
			</div>

			<% if ( score ) { %>
				<div class="score">
					<span class="num">
						<%- score %>
					</span>

					<span class="stars">
						<%= DT.stars_html( score ) %>
					</span>
				</div>
			<% } %>
		</div>
	</div>
</script>


<script type="text/template" id="t-zerg-aside">
	<div class="m-aside-content-widget">
		
<div id="zergnet-widget-40845" class="h-zerg-placeholder" data-dt-loc="content" data-id="40845" data-dt-refresh="0" data-dt-loc=aside"></div>
	</div>
</script>

<script type="text/template" id="t-fark-aside">
	<div class="m-aside-content-widget">
		<div id="unit_86356"><a href="http://fark.com/">News from Fark</a></div>	</div>
</script>

<script type="text/template" id="t-outbrain-aside">
	<div class="m-aside-content-widget">
		<div class="OUTBRAIN h-outbrain-placeholder h-outbrain-sidebar-placeholder" data-dt-loc="sidebar" data-src="http://www.digitaltrends.com/gaming/radeon-crimson-relive-17-4-4/" data-widget-id="SB_2" data-ob-template="Digital Trends"></div>
	</div>
</script>

<script>
	dt_smartsidebar_data_1171292 = {"items":[{"type":"post","date":"April 25, 2017","permalink":"http:\/\/www.digitaltrends.com\/computing\/nvidia-releases-geforce-38189-whql-drivers\/","title":"Nvidia&#8217;s latest GeForce drivers get you ready for &#8216;Warhammer 40,000: Dawn of War&hellip;","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/nvidia-chip-1200x0-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 20, 2017","permalink":"http:\/\/www.digitaltrends.com\/computing\/users-flash-amd-radeon-rx-470-and-480-cards-with-rx-570-and-580-firmware\/","title":"If you&#039;re brave, you can flash older AMD Radeon cards to get next-gen performance","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/radeon-rx-570-inhand2-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 25, 2017","permalink":"http:\/\/www.digitaltrends.com\/computing\/amd-poland-facebook-page-promises-vega-release-this-quarter\/","title":"AMD slips up as leak indicates its Vega GPUs are coming &#8216;this quarter&#8217;","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/amd-radeon-rx480-press-10-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 24, 2017","permalink":"http:\/\/www.digitaltrends.com\/mobile\/moto-g-problems\/","title":"20 glitches and bugs with the Moto G, and how to fix them","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/moto-g-desk-cases-90x90-c.jpg?ver=2","classes":"post","score":""},{"type":"post","date":"April 25, 2017","permalink":"http:\/\/www.digitaltrends.com\/computing\/sapphire-pulse-500\/","title":"Sapphire Pulse RX 500 cards ditch high-end cooling for a cheaper price tag","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/sapphirepulse-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 26, 2017","permalink":"http:\/\/www.digitaltrends.com\/gaming\/project-scorpio-news-and-rumors\/","title":"Xbox Project Scorpio: Everything you need to know about Microsoft&#8217;s newest console","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/project-scorpio-6-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 26, 2017","permalink":"http:\/\/www.digitaltrends.com\/computing\/amd-driver-update-adds-power-plan-for-optimized-performance\/","title":"Latest AMD Ryzen chipset drivers are good news for Windows 10 64-bit users","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/amd-ryzen-1600x-centerturned-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 26, 2017","permalink":"http:\/\/www.digitaltrends.com\/mobile\/oneplus-2-problems\/","title":"20 annoying OnePlus 2 problems, and how to fix them","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/oneplus2_-90x90-c.jpg","classes":"post","score":""},{"type":"post","date":"April 22, 2017","permalink":"http:\/\/www.digitaltrends.com\/gaming\/how-to-build-your-own-nes-classic-from-a-rasberry-pi\/","title":"Missed out on the NES Classic? Don\u2019t worry, building one is easier than you think","thumb":"http:\/\/icdn2.digitaltrends.com\/image\/raspberry-pi-nintendo-emulator-0003-2-90x90-c.jpg","classes":"post","score":""}]};</script>



		<div class="l-content-wrap">
			

<div class="m-newsletter-minimal  h-register-newsletter">

	<div class="line-1 h-message">Get today's popular <strong>Digital&nbsp;Trends</strong> articles in your inbox:</div>


	<form class="h-form" method="post">
		<input type="text" class="field h-field" name="dt_newsletter_register_email" placeholder="Enter your email">

		<input type="hidden" name="dt_newsletter_source" value="dt-newsletter-above-content">
		<input type="hidden" name="dt_lists[]" value="DT Newsletter">

		<input type="text" name="robot" value="" style="display:none">

		<input type="submit" class="submit h-submit" value="Sign Up">
	</form>

</div>

			<article class="m-content " itemprop="articleBody" data-scope="content">

				
<div class="m-quick-take m-quick-take--left">
    <div class="title">
        Why it matters to you    </div>
            <p class="bullet">Gamers who utilize a Radeon graphics card will want to grab these drivers post-haste -- especially if they're planning on doing battle in Dawn of War III.</p>
    </div>
<p>AMD released version 17.4.4 of its Radeon Software Crimson ReLive Edition drivers, which fixes several known issues and ensure that gamers can be confident they are getting the best possible performance from their hardware setup. The latest iteration of the package should be warmly received by users planning to put their AMD graphics card to work while running <em>Warhammer 40,000: Dawn of War III</em>.</p>
<p>Version 17.4.4 adds support for the hotly anticipated real-time strategy game. The company claims that the drivers offer improvements to performance as great as seven percent when measured against a Radeon RX 580 8GB graphics card utilizing Version 17.4.3 of Radeon Software Crimson ReLive Edition.</p>
<p>Alongside support for <em>Dawn of War III</em>, which launched on Thursday, the drivers also implement a host of other bug fixes. For one, the issue causing corruption as a result of the use of HDMI scaling on certain monitors has seemingly been taken care of, according to materials released by AMD.</p>
<p>In terms of other recent releases, <em>Battlefield 1</em> should no longer stutter while in Multi GPU mode at 4K display resolutions with DirectX 11 being employed. Meanwhile, <em>Mass Effect: Andromeda</em> will display HDR colors correctly on systems running the Creators Update for Windows 10, an issue that had plagued gamers since Microsoft released the update <a href='http://www.digitaltrends.com/computing/windows-10-creators-update-review/'>earlier this month</a>.</p>
<p>Additionally, graphics cards that are part of the Radeon RX 550 series should no longer suffer a hard hang when the user has not rebooted the system for a long period of time.</p>
<p>A reboot prompt has been reinstated to the Radeon Software installation process, which was apparently liable to disappear as a result of a conflict with AMD XConnect technology system configurations. Finally, some incorrect or unavailable feature descriptions have been addressed in the Radeon Settings menu.</p>
<p>Full release notes, instructions, and installation packages for various operating systems are available from AMD&#8217;s <a href="https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-17.4.4-Release-Notes.aspx" target="_blank" rel="noopener noreferrer">support site</a>.</p>

                <span itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
                    <span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                        <meta itemprop="url" content="http://cdn.dtcn.com/dt/dt-logo-small.png">
                        <meta itemprop="width" content="0">
                        <meta itemprop="height" content="0">
                    </span>
                    <meta itemprop="name" content="Digital Trends">
                </span>

			</article>

			
							<div class="m-signoff"></div>
			
			
<div class="m-content-widget  zerg">
	
<div id="zergnet-widget-41681" class="h-zerg-placeholder" data-dt-loc="content" data-id="41681" data-dt-refresh="0" ></div>
</div>
<section
	class="m-comments"
	id="comments-1171292"
	data-post-id="1171292"
	data-comments-open="1"
	data-comments-order="desc"
	data-logout-url="http://www.digitaltrends.com/wp-login.php?action=logout&amp;redirect_to=http%3A%2F%2Fwww.digitaltrends.com%2Fgaming%2Fradeon-crimson-relive-17-4-4%2F&amp;_wpnonce=27042fdf0c"
	data-comment-count="0"
	data-comment-module="facebook"
	data-scope="comments"
>

	<div class="above-comment-list"></div>

	<div class="m-comments--count total-count"></div>

	<div class="m-comments--expand">
		<div class="comment-list-container"></div>

		<div class="below-comment-list"></div>
	</div>

</section>
		</div>

	</div>

	

<div class="m-blockboard dtads-collapse-mobile ">
	<div class="m-blockboard--inner">
		<div class="l-block">
			<div class="dtads-slot dtads-slot-board dtads-desktop dtads-tablet" data-type="board" ></div>		</div>
	</div>
</div>

	<div class="l-block">

		<section class="m-grid-river" data-scope="infinite-discovery">
			<div class="m-grid-river--items l-1-hero-3-item infinite" id="h-river"></div>
		</section>

		<script>
			DTEvent.getEventPromise( 'dt:infinite:init' ).then( function() {

				var infinite_river = new DT.Infinite.Elements( {
					container_id: 'h-river',
					el_class:     'm-grid-river--group',
					fill_on_load: false,
					ajax_action:  'dt_infinite_discovery_ajax',
					ajax_data: {
						term: '6',
						post: '1171292'
					}
				});

			});
		</script>

	</div>

</div>

<script>
	var dt_premium_toc = setInterval(function() {
		if ( 'undefined' !== typeof DT_AWARDS_TOC ) {
			clearInterval( dt_premium_toc );
			new DT_AWARDS_TOC();
		}
	}, 200);
</script>



	</div>

	<script type="text/template" id="t-carousel-gallery">
	<div class="m-carousel-gallery--wrap h-wrap">
		<div class="m-carousel-gallery--slides h-slides"></div>

		<div class="m-carousel-gallery--controls h-controls">
			<div class="shift next h-next">
				<a href="javascript:">Next</a>
			</div>

			<div class="shift prev h-prev">
				<a href="javascript:">Previous</a>
			</div>

			<div class="m-carousel-gallery--dots h-pos-dots"></div>

			<div class="m-carousel-gallery--num h-pos-text">
				<span class="current h-pos-text-current"></span> of <span class="total h-pos-text-total"></span>
			</div>

			<div class="m-carousel-gallery--autoplay h-autoplay">
				<div>Video starting in <span class="seconds h-autoplay-seconds"></span></div>
			</div>
		</div>

		<div class="m-carousel-gallery--player h-player h-sticky-video m-sticky-video"></div>
	</div>

	<div class="m-carousel-gallery--close h-close">
		<a href="javascript:">Close Video</a>
	</div>

	<div class="m-carousel-gallery--meta h-meta">
		<div class="m-carousel-gallery--content h-content"></div>
	</div>
</script>

<script type="text/template" id="t-carousel-gallery-pos-dots">
	<div class="dot h-pos-dots-dot">
		<a href="javascript:"></a>
	</div>
</script>

<script type="text/template" id="t-carousel-gallery-loader">
	<div class="m-carousel-gallery--loader">
		<div class="inner">
			<div class="a"></div>
			<div class="b"></div>
			<div class="c"></div>
		</div>
	</div>
</script>

<script type="text/template" id="t-carousel-gallery-play">
	<div class="m-carousel-gallery--play">
		<a href="javascript:">Play</a>
	</div>
</script><script type="text/template" id="t-videoplayer-container">
	<div class="m-videoplayer--inner h-inner">
		<div class="m-videoplayer--wrap h-wrap">
			<div class="m-videoplayer--player h-player"></div>

			<div class="m-videoplayer--meta h-player-meta"></div>

			<div class="m-videoplayer--message h-player-message"></div>

			<div class="m-videoplayer--drawer h-drawer">
				<div class="m-videoplayer--panel playlist">
					<div class="m-videoplayer--jump">
						<select class="jump h-playlist-jump"></select>
					</div>

					<div class="m-videoplayer--pane h-playlist-pane">
						<div class="m-videoplayer--items h-playlist-items"></div>
					</div>
				</div>

				<div class="m-videoplayer--panel search">
					<div class="m-videoplayer--term">
						<div class="label">Results for</div>

						<div class="term h-search-term"></div>
					</div>

					<div class="m-videoplayer--pane h-search-pane">
						<div class="m-videoplayer--items h-search-items"></div>
					</div>
				</div>

				<div class="m-videoplayer--search">
					<div class="close h-search-clear">Clear search</div>

					<input class="field h-search-field" type="text" placeholder="Find Videos">
				</div>
			</div>
		</div>
	</div>

	<div class="m-videoplayer--loader">
		<div class="inner">
			<div class="a"></div>
			<div class="b"></div>
			<div class="c"></div>
		</div>
	</div>
</script>


<script type="text/template" id="t-videoplayer-item">
	<% var id = (typeof id === 'string') ? id : '' %>
	<% var title = (typeof title === 'string') ? title : '' %>
	<% var thumb = (typeof thumb === 'string') ? thumb : '' %>
	<% var is_playing = (typeof is_playing !== 'undefined' && is_playing) ? 'is-playing' : '' %>
	<% var is_next = (typeof is_next !== 'undefined' && is_next) ? 'is-next' : '' %>

	<div class="item <%- is_playing %> <%- is_next %> h-item" data-id="<%- id %>">
		<div class="inner">
			<div class="meta">
				<% if (title) { %>
					<div class="title"><%= title %></div>
				<% } %>
			</div>

			<% if (thumb) { %>
				<div class="thumb" style="background-image: url('<%= thumb %>');"></div>
			<% } %>
		</div>
	</div>
</script>


<script type="text/template" id="t-videoplayer-meta">
	<% var title = (typeof title === 'string') ? title : '' %>
	<% var play_count = (typeof play_count !== 'undefined') ? parseInt(play_count) || 0 : 0 %>
	<% var author = (typeof author === 'string') ? author : '' %>
	<% var date = (typeof date === 'string') ? date : '' %>
	<% var plural = (play_count > 1) ? 's' : '' %>

	<% if (title) { %>
		<div class="label">Now Playing</div>

		<% if (play_count) { %>
			<div class="count"><%= play_count %> Play<%= plural %></div>
		<% } %>

		<div class="title"><%= title %></div>

		<% if (author) { %>
			<div class="author">By <strong><%= author %></strong></div>
		<% } %>

		<% if (date) { %>
			<div class="date"><%= date %></div>
		<% } %>
	<% } %>
</script>


<script type="text/template" id="t-videoplayer-message">
	<% var label = (typeof label === 'string') ? label : '' %>
	<% var text = (typeof text === 'string') ? text : '' %>

	<div class="label"><%= label %></div>

	<div class="text"><%= text %></div>
</script>

			<!-- Begin DT Ads -->
			<script type="text/javascript">
				var dtads_slot_types = {"out_of_page":{"class":"dtads-out-of-page","keyvals":{"type":"roadblock"}},"leaderboard":{"class":"dtads-slot-leaderboard","sizes":[[728,90],[950,250],[970,66],[970,90],[970,250],[970,418],[970,200],[940,230],[970,300]],"keyvals":{"type":"roadblock","loc":"atf"}},"leaderboard_limited":{"class":"dtads-slot-leaderboard","sizes":[[728,90]],"keyvals":{"type":"roadblock","loc":"atf"}},"leaderboard_tablet":{"class":"dtads-slot-leaderboard-tablet","sizes":[[728,90],[728,230]],"keyvals":{"type":"roadblock","loc":"atf"}},"leaderboard_mobile":{"class":"dtads-slot-leaderboard-mobile","sizes":[[320,50],[320,100]],"keyvals":{"loc":"atf"}},"board":{"class":"dtads-slot-board","sizes":[[728,90]]},"mpu":{"class":"dtads-slot-mpu","sizes":[[300,250]]},"mpu_roadblock":{"class":"dtads-slot-mpu-roadblock","sizes":[[300,250]],"keyvals":{"type":"roadblock","loc":"atf"}},"mpu_sticky":{"class":"dtads-slot-mpu-sticky","sizes":[[300,250]],"keyvals":{"loc":"sticky"}},"mpu_content":{"class":"dtads-slot-mpu-content","sizes":[[300,250]],"keyvals":{"loc":"content"}},"mpu_content_mobile":{"class":"dtads-slot-mpu-content-mobile","sizes":[[320,50],[320,100],[300,50],[300,250],[320,480]],"keyvals":{"loc":"content"}},"halfpage":{"class":"dtads-slot-half","sizes":[[300,250],[300,600],[300,900],[300,1050]]},"halfpage_roadblock":{"class":"dtads-slot-half-roadblock","sizes":[[300,250],[300,600],[300,900],[300,1050]],"keyvals":{"type":"roadblock","loc":"atf"}}};
				var dtads_unit_name  = '/5611/dt.dgt.www';
				var dtads_keyvals    = {"tags":["amd","radeon","radeon-software-crimson-relive-edition","warhammer-40000-dawn-of-war-iii"],"cat":["computing","gaming","trending"],"supports":["bt","mp","skin"],"aid":1171292};
				var dtads_lazy       = false;
			</script>
			<!-- End DT Ads -->

			<div id="dt-dc-footer-components-0" ></div><div id="dt-dc-linked-keywords-injection-0" ></div><div id="dt-dc-wp_admin_toolbar-0" ></div>			<script>
			window['dt_dynamic_components'] = "{\"share-count\":[{\"name\":\"share-count\",\"args\":{\"type\":\"comment\",\"object_id\":1171292,\"taxonomy\":\"\"},\"i\":0},{\"name\":\"share-count\",\"args\":{\"type\":\"facebook\",\"object_id\":1171292,\"taxonomy\":\"\"},\"i\":1}],\"footer-components\":[{\"name\":\"footer-components\",\"args\":null,\"i\":0}],\"linked-keywords-injection\":[{\"name\":\"linked-keywords-injection\",\"args\":{\"post_id\":1171292},\"i\":0}],\"wp_admin_toolbar\":[{\"name\":\"wp_admin_toolbar\",\"args\":{\"post_id\":1171292},\"i\":0}]}";
			</script>
					<script>
			(function( $, vent ){

				vent.on( 'dt:dynamic_components:user_data_available', function( user_data ){

					dataLayer.push({
						'logged_in': 1,
						'user_id': user_data.user_ID,
						'client_ip': user_data.ip_address,
						'user_roles': user_data.roles
					});

				} );

				vent.on( 'dt:dynamic_components:guest_ip_available', function( ip_address ){

					dataLayer.push({
						'logged_in': 0,
						'client_ip': ip_address
					});

				} );

				vent.on( 'dt:dynamic_components:user_ready', function(){

					dataLayer.push({
						'event': 'user_ready'
					});

				} );

				
			}( jQuery, DTEvent ) );
		</script>
		<script>var dtads_inject_ad_slot_html = { desktop: '<div class="dtads-slot dtads-slot-mpu-content dtads-desktop dtads-tablet" data-type="mpu_content" ></div>', tablet: '<div class="dtads-slot dtads-slot-mpu-content dtads-desktop dtads-tablet" data-type="mpu_content" ></div>', mobile: '<div class="dtads-slot dtads-slot-mpu-content-mobile dtads-mobile" data-type="mpu_content_mobile" ></div>' };</script>		<script>
			(function() {
				DTEvent.getEventPromise('dtads:adblock:done').then(function(data) {
					var val, script_el, head_el;

					val = (data.length && data[0]) ? '1' : '0';

					window._sp_ = {};
					window._sp_.config = {};
					window._sp_.config.custom_beacon_entries = [val];

					script_el       = document.createElement('script');
					script_el.type  = 'text/javascript';
					script_el.async = true;
					script_el.src   = '//d2lv4zbk7v5f93.cloudfront.net/esf.js';
					script_el.setAttribute('data-client-id', 'LgYcoykZxpElfbn');

					head_el = document.getElementsByTagName('head')[0];
					head_el.insertBefore(script_el, head_el.firstChild);
				});
			})();
		</script>
				<script type="text/javascript">
		    (function() {
		        function async_load(script_url){
		            var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
		            var s = document.createElement('script'); s.src = protocol + script_url;
		            var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
		        }
		        bm_website_code = '0895AF997E114BC5';
		        jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
		        jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
		    })();
		</script>
					<script type="text/template" id="t-topic-newsletter-signup-modal">

				<div class="m-modal m-topic-newsletter-signup-modal h-topic-newsletter-signup-modal">

					<div class="m-modal--wrap">

						<div class="m-modal--view">
							<h3 class="m-modal--big-text">
								Get future <span class="tag">Gaming</span> content delivered straight to your inbox
							</h3>
						</div>

						<div class="m-modal--form m-base-form fat">
							<div class="field-block">
								<input class="h-email-topic-newsletter-signup-modal" type="text" maxlength="1280" placeholder="Your email" />
							</div>

							<div class="block final">
								<div class="button h-submit-topic-newsletter-signup-modal" data-tag="gaming">Submit</div>
							</div>
						</div>

					</div>
				</div>

			</script>

			<script type="text/template" id="t-topic-newsletter-success-modal">

				<div class="m-modal m-topic-newsletter-success-modal h-topic-newsletter-success-modal">

					<div class="m-modal--wrap">

						<div class="m-modal--view">
							<h3 class="m-modal--big-text">
								<span>Success!</span>
							</h3>
						</div>

						<div class="m-modal--form m-base-form fat">
							<div class="block final">
								<a class="button" href="http://www.digitaltrends.com/newsletter-management?email=<%= email %>">Manage Your <span>Subscriptions</span></a>
								<a class="close h-close-success-modal" href="javascript:void(0)">Close</a>
							</div>
						</div>

					</div>
				</div>

			</script>
			
		<script type="text/template" id="t-comments">
			<section
	class="m-comments"
	id="comments-1171292"
	data-post-id="1171292"
	data-comments-open="1"
	data-comments-order="desc"
	data-logout-url="http://www.digitaltrends.com/wp-login.php?action=logout&amp;redirect_to=http%3A%2F%2Fwww.digitaltrends.com%2Fgaming%2Fradeon-crimson-relive-17-4-4%2F&amp;_wpnonce=27042fdf0c"
	data-comment-count="0"
	data-comment-module="facebook"
	data-scope="comments"
>

	<div class="above-comment-list"></div>

	<div class="m-comments--count total-count"></div>

	<div class="m-comments--expand">
		<div class="comment-list-container"></div>

		<div class="below-comment-list"></div>
	</div>

</section>		</script>

		<!-- Sailthru Horizon Sync -->
<script type="text/javascript" src="//ak.sail-horizon.com/horizon/v1.js"></script>
<script type="text/javascript">
jQuery(function() { 
  if (window.Sailthru) {
           Sailthru.setup({
              domain:'horizon.digitaltrends.com'
         });
  }
});
 </script>
<link rel='stylesheet' id='dropcap_stylesheet-css'  href='http://cdn5.digitaltrends.com/wp-content/plugins/drop-cap-shortcode/css/style.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript' src='http://cdn1.digitaltrends.com/wp-content/plugins/sailthru-widget/js/widget.subscribe.js?ver=3.0.5'></script>
<script type='text/javascript' src='http://content.jwplatform.com/libraries/ERPbx32c.js?ver=ERPbx32c' id="jwplayer-script" async></script>
<script type='text/javascript' src='http://cdn2.digitaltrends.com/wp-content/mu-plugins/dt-videos/assets/scripts/dtvideos.js?ver=1493313007' async></script>
<script type='text/javascript' src='http://cdn3.digitaltrends.com/wp-content/themes/digitaltrends-2014/assets/scripts/js/dt-foot.min.js?ver=1493051905961'></script>
<script type='text/javascript' src='http://cdn3.digitaltrends.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>

	<div class="l-pxl-destroyer"></div>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"053881f822","applicationID":"1100784","transactionName":"MgADYEpXXBVXAk1RDgtKIFdMX10IGRJQVgYJAExEV0VG","queueTime":0,"applicationTime":257,"atts":"HkcUFgJNT0oUABsCGhgY","errorBeacon":"bam.nr-data.net","agent":""}</script></body>

</html>