<!DOCTYPE html>
<html lang="en" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

<head  prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
	<meta charset="UTF-8">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

	

				<script id="Cookiebot" src="https://consent.cookiebot.com/uc.js" data-framework="IAB" data-cbid="63b3b1c3-501e-4857-a443-1c4281f2a970" type="text/javascript" async></script>
			
<!-- This site is optimized with the Yoast SEO Premium plugin v12.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Best Buy Mobile Sale: Galaxy S20, Google Pixel 4, iPhone XS In The Discount Bin | Digital Trends</title>
<meta name="description" content="Best Buy is running a limited-time sale on some of the top flagship smartphones including the iPhone XS, Google Pixel 4, and Samsung Galaxy S20, and more."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.digitaltrends.com/dtdeals/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Best Buy Mobile Sale: Galaxy S20, Google Pixel 4, iPhone XS In The Discount Bin | Digital Trends" />
<meta property="og:description" content="Best Buy is running a limited-time sale on some of the top flagship smartphones including the iPhone XS, Google Pixel 4, and Samsung Galaxy S20, and more." />
<meta property="og:url" content="https://www.digitaltrends.com/dtdeals/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs/" />
<meta property="og:site_name" content="Digital Trends" />
<meta property="article:publisher" content="https://www.facebook.com/digitaltrends" />
<meta property="article:tag" content="Android" />
<meta property="article:tag" content="Deals" />
<meta property="article:tag" content="google pixel 4" />
<meta property="article:tag" content="iPhone" />
<meta property="article:tag" content="iphone xs" />
<meta property="article:tag" content="iPhone Xs Max" />
<meta property="article:tag" content="Mobile" />
<meta property="article:tag" content="phones" />
<meta property="article:published_time" content="2020-04-20T16:52:00+00:00" />
<meta property="og:image" content="https://icdn3.digitaltrends.com/image/digitaltrends/pixel-4-competitors-1200x630-c-ar1.91.jpg" />
<meta property="og:image:secure_url" content="https://icdn3.digitaltrends.com/image/digitaltrends/pixel-4-competitors-1200x630-c-ar1.91.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="630" />
			<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Best Buy is running a limited-time sale on some of the top flagship smartphones including the iPhone XS, Google Pixel 4, and Samsung Galaxy S20, and more." />
<meta name="twitter:title" content="Best Buy Mobile Sale: Galaxy S20, Google Pixel 4, iPhone XS In The Discount Bin | Digital Trends" />
<meta name="twitter:site" content="@digitaltrends" />
<meta name="twitter:image" content="https://icdn4.digitaltrends.com/image/digitaltrends/pixel-4-competitors-510x0.jpg" />
<meta name="twitter:creator" content="@Jarl_Lucas" />
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.digitaltrends.com' />
<link rel='dns-prefetch' href='//cdn5.digitaltrends.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Digital Trends | Feed" href="https://www.digitaltrends.com/feed/" />
<link rel="amphtml" href="https://www.digitaltrends.com/dtdeals/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs/?amp"><style id="dt-single-head-style">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</style>
<script type='text/javascript' src='https://cdn2.digitaltrends.com/wp-content/themes/dt-stardust/assets/scripts/js/vendor/vendor.1e400c4e.min.js?ver=1586805082364' defer></script>
<script id="dt-head-script">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</script>
<link rel='shortlink' href='https://www.digitaltrends.com/?p=2483739' />
			<script>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</script>
						<meta name="apple-itunes-app" content="app-id=500266645, affiliate-data=11lnN7">
		
			<!-- Begin GPT -->
			<script type="text/javascript">
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
					var gads = document.createElement('script');
					gads.async = true;
					gads.type = 'text/javascript';
					var useSSL = 'https:' == document.location.protocol;
					gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
					var node = document.getElementsByTagName('script')[0];
					node.parentNode.insertBefore(gads, node);
				})();
			</script>
			<!-- End GPT -->

						<script>
				(function() {
					'use strict';

					var l10ns = {"ahe084RE8hgWerv8":{"dt:aux-content-module:content_labels":{"insert_btn_label":"Insert Section Break","insert_menu_item_label":"Section break"},"dt-stardust-affiliate":{"buy_now":"Buy Now","price_disclaimer":"*Price may be subject to change","where_to_buy":"Where to Buy","shop":"Shop","buy_for_at":"Buy for $%price at %merchant","buy_from":"$%price from %merchant","buy_at":"Buy at %merchant"},"shortcode-timer":{"Days":"Days","Hours":"Hours","Minutes":"Minutes","Seconds":"Seconds"},"dt-stardust-membership":{"login":"Login","logout":"Logout","signup":"Sign Up","checkout":"Checkout","profile":"Profile","email_address":"Email Address","password":"Password","membership_plan":"Membership Plan","change_password":"Change Password","upgrade_plan":"Upgrade Plan","cancel_plan":"Cancel Subscription","standard_plan_label":"Standard","premium_plan_label":"Premium"},"newsletter-signup":{"signupPreferencesHeading":"Customize your weekly list with some of our top sections.","CuratedListsHeading":"Featured newsletters","NewsletterSignupHeading":"Stay Current.","NewsletterSignupSubHeading":"Get the latest <strong>Trending<\/strong> news straight to your inbox.","TopicListsHeading":"Add your favorite topics to the list too.","TopicListsSubheading":"Newsletters by category","SuccessTitle":"You're All Set!","SuccessMessage":"<strong>Thanks for signing up.<\/strong> We'll be sending you a <strong>confirmation email<\/strong> shortly.<br>In the meantime, check out the rest of our newsletters.","SuccessMessageShort":"<strong>Thanks for signing up.<\/strong> We'll be sending you a <strong>confirmation email<\/strong> shortly.","Select":"Select","Subscribe":"Subscribe","Okay":"Okay","Unselect":"Unselect","Unsubscribe":"Unsubscribe","SignUp":"Sign Up","Save":"Save","FinishAndSave":"Finish and save","SeeMore":"See More","Next":"Next","Selected":"Selected","Email":"Email","Done":"Done","EmailAddressInvalidError":"Email address is invalid","NoEmailAddressError":"No email address entered","NewslettersSelected":"Newsletters Selected","CuratedListHeading":"Select featured newsletters","CuratedListSubheading":"Our editors find the best stories so you don\u2019t have to.","TopicListHeading":"More categories you might like","TopicListSubheading":"Because we know you love options","ManagePreferencesHeading":"<span>Manage <\/span>Preferences","ManagePreferencesSubheading":"Select which newsletters you would like to receive","NewsletterSignupCallToAction":"Sign up for our <strong><\/strong> newsletter","NewsletterPrivacyLink":"Your <strong><a href='https:\/\/www.digitaltrends.com\/legal\/privacy-policy\/' target='_blank'>privacy<\/a><\/strong> is important to us!","AlreadySignedUpMessage":"You're signed up to receive <strong>ALL<\/strong> of our newsletters!?","AlreadySignedUpTitle":"Thanks, youre the best!","AlreadySignedUpButton":"I Know"},"site-head":{"currentArticle":"Now Reading","share":"Share","shopCTA":"Buy Now"},"video-home":{"play_all":"Play All","view_more":"View More","by":"By"},"video-player":{"empty_playlist":"<strong>Playlist is empty<\/strong> Choose another playlist or try searching"},"dt-live-video":{"live":"LIVE"}}};

					var get = function get(key, group) {
						key = key || '';
						group = group || 'ahe084RE8hgWerv8';

						if (typeof l10ns[group] !== 'undefined') {
							if (key && typeof l10ns[group][key] !== 'undefined') {
								return l10ns[group][key];
							}
						}

						return null;
					};

					window.DTL10n = {
						get: get,
					};
				}());
			</script>
							<script>
					[
						['CookiebotOnLoad', 'load'],
						['CookiebotOnAccept', 'accept'],
						['CookiebotOnDecline', 'decline'],
						['CookiebotOnDialogInit', 'dialog-init'],
						['CookiebotOnDialogDisplay', 'dialog-display'],
						['CookiebotOnTagsExecuted', 'tags-executed'],
					].forEach(function (v) {
						window.addEventListener(v[0], function (evt) {
							window.DTEvent.promise(`dtcookiebot:${v[1]}`, evt);
						});
					}, false);

					window.dtCookiebotAcceptedPromise = function() {
						return new Promise(function(resolve) {
							window.CookiebotCallback_OnAccept = function() {
								console.log('DTAds:Cookiebot consent accepted', Cookiebot.consent);

								// add regular consent data to the data layer
								if (Cookiebot.consent.preferences) {
									dataLayer.push({ event: 'cookieconsent_preferences' });
								}

								if (Cookiebot.consent.statistics) {
									dataLayer.push({ event: 'cookieconsent_statistics' });
								}

								if (Cookiebot.consent.marketing) {
									dataLayer.push({ event: 'cookieconsent_marketing' });
								}

								resolve(Cookiebot.consent);
							};

							window.CookiebotCallback_OnDecline = function() {
								resolve(Cookiebot.consent);
							};
						});
					};
				</script>
						<meta property="fb:app_id" content="61377565444"/>
			<script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.digitaltrends.com\/dtdeals\/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs\/"},"datePublished":"2020-04-20T09:52:00-07:00","dateModified":"2020-04-20T09:52:00-07:00","articleSection":"Deals","author":{"@type":"Person","name":"Lucas Coll"},"creator":{"@type":"Thing","name":"Lucas Coll"},"headline":"Best Buy Mobile Sale: Galaxy S20, Google Pixel 4, iPhone XS in the discount bin","url":"https:\/\/www.digitaltrends.com\/dtdeals\/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs\/","thumbnailUrl":"https:\/\/icdn2.digitaltrends.com\/image\/digitaltrends\/pixel-4-competitors.jpg","image":{"@type":"ImageObject","url":"https:\/\/icdn2.digitaltrends.com\/image\/digitaltrends\/pixel-4-competitors.jpg","width":4510,"height":3001},"publisher":{"@type":"Organization","name":"Digital Trends","url":"https:\/\/www.digitaltrends.com","logo":{"@type":"ImageObject","url":"https:\/\/cdn.dtcn.com\/dt\/dt-logo-small.png"}},"keywords":["Android","Deals","google pixel 4","iPhone","iphone xs","iPhone Xs Max","Mobile","phones"]},{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Deals","item":"https:\/\/www.digitaltrends.com\/dtdeals\/"}]}]</script>			<script type="text/javascript">
				var ajaxurl = 'https://www.digitaltrends.com/wp-content/themes/dt-stardust/ajax-actions.php';
				var ord 	= Math.random()*10000000000000000;
							</script>
			<style type="text/css" media="print">#wpadminbar { display:none; }</style>
	      <meta name="onesignal" content="wordpress-plugin"/>
        <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.digitaltrends.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '87a1768e-b153-4fcf-9039-77585a740492';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://www.digitaltrends.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.6b31cc7e-8212-45ce-95eb-ed8c35d3e69c";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

			<script>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</script>
						<script>
				window.dataLayer = window.dataLayer || [];
				(function(dtdata, dataLayer) {
					dataLayer.push(dtdata.getAll());
					dtdata.addCallback(function(key, val) {
						if (key) {
							if (typeof key == 'object') {
								dataLayer.push(key);
							} else {
								var obj = {};
								obj[key] = val;
								dataLayer.push(obj);
							}
						}
					});
				}(DTData, dataLayer));
			</script>
			
				<link rel="apple-touch-icon" sizes="180x180" href="https://cdn7.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/images/favicons/apple-touch-icon.png">
									<link rel="icon" type="image/png" size="32x32" href="https://www.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/images/favicons/favicon-32x32.png">
									<link rel="icon" type="image/png" size="16x16" href="https://www.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/images/favicons/favicon-16x16.png">
									<meta name="theme-color" content="#0095da">
						
	<meta name="viewport" content="minimum-scale=1, initial-scale=1, width=device-width, shrink-to-fit=no">
</head>

<body class="post-template-default single single-post postid-2483739 single-format-standard dt-body dt-single h-single-template"  data-post-id="2483739" data-post-type="post" data-primary-category="191036" >
				<!-- Google Tag Manager -->
			<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WKFXF7"
			height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
			<script>(function(w,d,s,l,i) {w[l]=w[l]||[];w[l].push({'gtm.start':
			new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
			j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
			'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			})(window,document,'script','dataLayer','GTM-WKFXF7');</script>
			<!-- End Google Tag Manager -->

			
	
			<div class="b-anterior">
			<div class="dtads-slot dtads-slot-atn dtads-desktop"></div>
			<div class="dtads-slot dtads-slot-atn-tablet dtads-tablet"></div>
			<div class="dtads-slot dtads-out-of-page dtads-desktop dtads-tablet dtads-mobile"></div>
		</div>
	
	
<header class="b-nav is-small h-nav-container">
			<a href="https://www.digitaltrends.com" class="b-nav__logo h-nav-logo">
			<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 231 45" width="231" height="45" alt="Digital Trends">
	<path fill="#fff" d="M56.9,17.42v9.9h2.87c3.06,0,5.05-2.06,5.05-4.91v-0.04c0-2.85-2-4.95-5.05-4.95L56.9,17.42L56.9,17.42z M54.34,15.09h5.43c4.57,0,7.73,3.14,7.73,7.24v0.04c0,4.1-3.16,7.28-7.73,7.28h-5.43V15.09z"/>
	<path fill="#fff" d="M70.75,15.09h2.56v14.55h-2.56V15.09z"/>
	<path fill="#fff" d="M76.55,22.41v-0.04c0-4.08,3.12-7.53,7.51-7.53c2.54,0,4.1,0.71,5.59,1.98l-1.62,1.93 c-1.12-0.94-2.22-1.54-4.08-1.54c-2.68,0-4.72,2.33-4.72,5.11v0.04c0,2.99,1.98,5.2,4.95,5.2c1.37,0,2.62-0.44,3.51-1.1v-2.7h-3.72 v-2.25h6.2v6.11c-1.43,1.23-3.49,2.27-6.07,2.27C79.54,29.9,76.55,26.65,76.55,22.41z"/>
	<path fill="#fff" d="M93.64,15.09h2.56v14.55h-2.56V15.09z"/>
	<path fill="#fff" d="M103.64,17.46H99v-2.37h11.83v2.37h-4.64v12.18h-2.56V17.46H103.64z"/>
	<path fill="#fff" d="M120.46,23.87l-2.52-5.82l-2.49,5.82H120.46z M116.8,14.99h2.37l6.4,14.66h-2.7l-1.48-3.51h-6.88l-1.5,3.51 h-2.62L116.8,14.99z"/>
	<path fill="#fff" d="M128.07,15.09h2.56v12.23h7.65v2.33h-10.21V15.09z"/>
	<polygon fill="#fff" points="147.2,18.41 142.83,18.41 142.83,15.09 155.32,15.09 155.32,18.41 150.93,18.41 150.93,29.65  147.2,29.65"/>
	<path fill="#fff" d="M164.07,22.11c1.43,0,2.27-0.73,2.27-1.85v-0.04c0-1.24-0.89-1.87-2.31-1.87h-2.86v3.76H164.07z M157.45,15.09 h6.8c2.08,0,3.58,0.56,4.55,1.53c0.84,0.84,1.27,1.96,1.27,3.37v0.04c0,2.28-1.22,3.76-3.04,4.5l3.5,5.12h-4.3l-3-4.5h-2.06v4.5 h-3.72L157.45,15.09L157.45,15.09z"/>
	<polygon fill="#fff" points="172.55,15.09 183.98,15.09 183.98,18.29 176.24,18.29 176.24,20.79 183.18,20.79 183.18,23.85  176.24,23.85 176.24,26.44 184.09,26.44 184.09,29.65 172.55,29.65"/>
	<polygon fill="#fff" points="186.57,15.09 190.03,15.09 196.33,23.26 196.33,15.09 200.01,15.09 200.01,29.65 196.79,29.65  190.25,21.19 190.25,29.65 186.57,29.65"/>
	<path fill="#fff" d="M206.77,18.4v7.93h1.95c2.5,0,4.17-1.49,4.17-3.93v-0.04c0-2.42-1.66-3.96-4.17-3.96H206.77z M203.05,15.09 h5.65c4.95,0,8.02,3.05,8.02,7.21v0.04c0,4.16-3.1,7.3-8.07,7.3h-5.6V15.09z"/>
	<path fill="#fff" d="M217.94,27.5l2.11-2.53c1.4,1.12,2.9,1.76,4.58,1.76c1.18,0,1.84-0.43,1.84-1.14v-0.04 c0-0.69-0.48-1.05-2.65-1.58c-3.03-0.74-5.24-1.57-5.24-4.52v-0.04c0-2.68,2.13-4.56,5.43-4.56c2.34,0,4.23,0.67,5.77,1.9 l-1.88,2.68c-1.32-0.93-2.7-1.43-3.97-1.43c-1.07,0-1.61,0.46-1.61,1.06v0.04c0,0.78,0.54,1.08,2.76,1.6 c3.19,0.75,5.11,1.82,5.11,4.47v0.04c0,2.94-2.29,4.66-5.68,4.66C222.08,29.88,219.73,29.09,217.94,27.5z"/>
	<rect x="0.11" y="0.11" fill="#fff" width="44.78" height="44.77"/>
	<path fill="#0094e5" d="M0,0v45h45V0H0z M8.44,26.44h5.62v4.5H8.44V26.44z M18.56,36.56H8.44v-4.5h10.12V36.56z M36.56,25.31H25.31 v11.25h-5.62V25.31H8.44v-5.62h11.25l0,0l0,0V8.44h5.62v11.25h11.25V25.31z"/>
</svg>
		</a>
	
	
	<button class="b-nav__back h-nav-back-button">
		Back to Menu	</button>

	<ul class="b-nav__items-0 h-nav-items">
		<li class="b-nav__button-item h-nav-parent-item">
			<button class="b-nav__button b-nav__button--search">
				<span class="is-visually-hidden">
					Search				</span>
			</button>

			<div class="b-nav__drawer">
				<form class="b-nav__search" action="https://www.digitaltrends.com" method="get">
					<input type='text' name='s' autoFocus>
					<input type='submit' value="Search">
				</form>
			</div>
		</li>

		<li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="https://www.digitaltrends.com/best-products/?itm_medium=nav" >Best Products</a><ul class="b-nav__items-1"><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-laptops/?itm_medium=nav" >Best Laptops</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/best-headphones/?itm_medium=nav" >Best Headphones</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/gaming/best-games/?itm_medium=nav" >Best Games</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/gaming/best-gaming-consoles/?itm_medium=nav" >Best Game Consoles</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/mobile/best-tablets/?itm_medium=nav" >Best Tablets</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/cool-tech/best-drones/?itm_medium=nav" >Best Drones</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/cars/best-cars/?itm_medium=nav" >Best Cars</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-wireless-routers/?itm_medium=nav" >Best Routers</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/mobile/best-smartphones/?itm_medium=nav" >Best Phones</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-printers/?itm_medium=nav" >Best Printers</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/best-speakers/?itm_medium=nav" >Best Speakers</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/best-tvs/?itm_medium=nav" >Best TVs</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/best-soundbars/?itm_medium=nav" >Best Soundbars</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-home-security-systems/?itm_medium=nav" >Best Home Security Systems</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/photography/best-digital-cameras/?itm_medium=nav" >Best Cameras</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/wearables/best-smartwatch/?itm_medium=nav" >Best Smartwatches</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-smart-home-devices/?itm_medium=nav" >Best Smart Home Devices</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-refrigerators/?itm_medium=nav" >Best Refrigerators</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-dishwashers/?itm_medium=nav" >Best Dishwashers</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-washing-machines/?itm_medium=nav" >Best Washing Machines</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/best-streaming-devices/?itm_medium=nav" >Best Streaming Devices</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-desktop-computers/?itm_medium=nav" >Best Desktops</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/best-coffee-makers/?itm_medium=nav" >Best Coffee Machines</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/topic/versus/?itm_medium=nav" >Versus</a></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/best-products/?itm_medium=nav" >More Best Products</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="https://www.digitaltrends.com/product-reviews/?itm_medium=nav" >Product Reviews</a><ul class="b-nav__items-1"><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/laptop-reviews/?itm_medium=nav" >Laptop Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/tv-reviews/?itm_medium=nav" >TV Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/tablet-reviews/?itm_medium=nav" >Tablet Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/game-reviews/?itm_medium=nav" >Game Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/sound-bar-reviews/?itm_medium=nav" >Soundbar Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/digital-camera-reviews/?itm_medium=nav" >Camera Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/printer-reviews/?itm_medium=nav" >Printer Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/drone-reviews/?itm_medium=nav" >Drone Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/headphone-reviews/?itm_medium=nav" >Headphone Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/fitness-tracker-reviews/?itm_medium=nav" >Fitness Tracker Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/cell-phone-reviews/?itm_medium=nav" >Phone Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/monitor-reviews/?itm_medium=nav" >Monitor Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/smartwatch-reviews/?itm_medium=nav" >Smartwatch Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/appliance-reviews/?itm_medium=nav" >Appliance Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-security-reviews/?itm_medium=nav" >Home Security Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/speaker-reviews/?itm_medium=nav" >Speaker Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/desktop-computer-reviews/?itm_medium=nav" >Desktop Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/car-reviews/?itm_medium=nav" >Car Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/media-streamer-reviews/?itm_medium=nav" >Streaming Device Reviews</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/smart-home-reviews/?itm_medium=nav" >Smart Home Device Reviews</a></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/product-reviews/?itm_medium=nav" >All Reviews</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="https://www.digitaltrends.com/news/?itm_medium=nav" >News</a><ul class="b-nav__items-1"><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/mobile/?itm_medium=nav" >Mobile</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/?itm_medium=nav" >Home Theater</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/?itm_medium=nav" >Computing</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/gaming/?itm_medium=nav" >Gaming</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/cars/?itm_medium=nav" >Cars</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/photography/?itm_medium=nav" >Photography</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/wearables/?itm_medium=nav" >Wearables</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/cool-tech/?itm_medium=nav" >Emerging Tech</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/movies/?itm_medium=nav" >Entertainment</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/business/?itm_medium=nav" >Small Business</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/topic/coronavirus/?itm_medium=nav" >Coronavirus</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/social-media/?itm_medium=nav" >Culture</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/5g/?itm_medium=nav" >5G</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/?itm_medium=nav" >Smart Home</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/smart-cities/?itm_medium=nav" >Smart Cities</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/topic/artificial-intelligence/?itm_medium=nav" >Artificial Intelligence</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/topic/cybersecurity/?itm_medium=nav" >Cybersecurity</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/topic/internet-of-things/?itm_medium=nav" >Internet of Things (IoT)</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/netflix/?itm_medium=nav" >Netflix</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/samsung/?itm_medium=nav" >Samsung</a></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/news/?itm_medium=nav" >More News</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="#" >Original Series</a><ul class="b-nav__items-1"><li class="b-nav__item-1 b-nav__item-1--parent" ><a href="#" >Original Series</a><ul class="b-nav__items-2"><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/live/?itm_medium=nav" >Digital Trends Live</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/topic/bold-ideas/?itm_medium=nav" >Bold Ideas</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/topic/schools-out/?itm_medium=nav" >School's Out</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/tech-for-change/?itm_medium=nav" >Tech for Change</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/topic/innovation-through-collaboration/?itm_medium=nav" >Innovate / Collaborate</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/women-with-byte/?itm_medium=nav" >Women With Byte</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/topic/the-food-fight/?itm_medium=nav" >The Food Fight</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/features/?itm_medium=nav" >Special Features</a></li></ul></li><li class="b-nav__item-1 b-nav__item-1--parent" ><a href="#" >Video Series</a><ul class="b-nav__items-2"><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/podcasts/trends-with-benefits-podcast/?itm_medium=nav" >Trends with Benefits</a></li><li class="b-nav__item-2" ><a href="https://www.youtube.com/channel/UC8wXC0ZCfGt3HaVLy_fdTQw?sub_confirmation=1" >Hands-On</a></li><li class="b-nav__item-2" ><a href="https://www.youtube.com/channel/UC8wXC0ZCfGt3HaVLy_fdTQw?sub_confirmation=1" >Vs.</a></li><li class="b-nav__item-2" ><a href="https://www.youtube.com/channel/UC8wXC0ZCfGt3HaVLy_fdTQw?sub_confirmation=1" >Desk Envy</a></li><li class="b-nav__item-2" ><a href="https://www.youtube.com/channel/UC8wXC0ZCfGt3HaVLy_fdTQw?sub_confirmation=1" >Explained</a></li><li class="b-nav__item-2" ><a href="https://www.youtube.com/playlist?list=PLZEIwIHCxaFUYfBEBhqMty44n7_2lR1eC" >The Deets</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/topic/reel-news/?itm_medium=nav" >Reel News</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/jargon/?itm_medium=nav" >Jargon</a></li></ul></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/topic/original-series/?itm_medium=nav" >More Originals</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="https://www.digitaltrends.com/buying-guides/?itm_medium=nav" >Buying Guides</a><ul class="b-nav__items-1"><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/qled-vs-oled-tv/?itm_medium=nav" >QLED vs. OLED TV</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/which-instant-pot-should-you-buy/?itm_medium=nav" >Which Instant Pot Should You Buy?</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/mobile/google-pixel-4-xl-vs-samsung-galaxy-note-10-plus/?itm_medium=nav" >Pixel 4 XL vs. Galaxy Note 10 Plus</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/gaming/nintendo-switch-vs-ps4/?itm_medium=nav" >Nintendo Switch vs. PS4</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/mobile/apple-iphone-11-pro-max-vs-samsung-galaxy-note-10-plus/?itm_medium=nav" >iPhone 11 Pro Max vs. Galaxy Note 10 Plus</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/gaming/xbox-one-vs-ps4/?itm_medium=nav" >Xbox One vs. PS4</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/google-nest-mini-vs-google-home-mini/?itm_medium=nav" >Google Nest Mini vs. Home Mini</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/google-home-mini-vs-amazon-echo-dot/?itm_medium=nav" >Google Home Mini vs. Amazon Echo Dot</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home-theater/4k-tv-buying-guide/?itm_medium=nav" >4K TV Buying Guide</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/home/google-home-vs-amazon-echo/?itm_medium=nav" >Google Home vs. Amazon Echo</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/laptop-buying-guide/?itm_medium=nav" >Laptop Buying Guide</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/photography/digital-camera-buying-guide/?itm_medium=nav" >Digital Camera Buying Guide</a></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/buying-guides/?itm_medium=nav" >More Buying Guides</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="https://www.digitaltrends.com/deals/?itm_medium=nav" >Deals</a><ul class="b-nav__items-1"><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-ipad-deals/?itm_medium=nav" >Best iPad Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-apple-watch-deals/?itm_medium=nav" >Best Apple Watch Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-iphone-deals/?itm_medium=nav" >Best iPhone Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-cheap-macbook-deals/?itm_medium=nav" >Best MacBook Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-4k-tv-deals/?itm_medium=nav" >Best 4K TV Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-smartwatch-deals/?itm_medium=nav" >Best Smartwatch Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/computing/best-laptop-deals/?itm_medium=nav" >Best Laptop Deals</a></li><li class="b-nav__item-1" ><a href="https://www.digitaltrends.com/dtdeals/best-smartphone-deals/?itm_medium=nav" >Best Smartphone Deals</a></li><li class="b-nav__item-1 more" ><a href="https://www.digitaltrends.com/deals/?itm_medium=nav" >More Deals</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item" ><a href="#" >Downloads</a><ul class="b-nav__items-1"><li class="b-nav__item-1 b-nav__item-1--parent" ><a href="#" >Categories</a><ul class="b-nav__items-2"><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/office-productivity" >Office & Productivity</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/development-tools" >Development Tools</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/learning" >Learning</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/games" >Games</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/internet" >Internet</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/music-video" >Music & Video</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/customization" >Customization</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/security-vpn" >Security & VPN</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/social-messaging" >Social & Messaging</a></li></ul></li><li class="b-nav__item-1 b-nav__item-1--parent" ><a href="#" >Platforms</a><ul class="b-nav__items-2"><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com" >Windows</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/mac" >Mac</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/android" >Android</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/os-tools" >OS & Tools</a></li><li class="b-nav__item-2" ><a href="https://downloads.digitaltrends.com/windows/browsers" >Browsers</a></li></ul></li><li class="b-nav__item-1 more" ><a href="https://downloads.digitaltrends.com/" >More Downloads</a></li></ul></li><li class="b-nav__item-0 b-nav__item-0--parent h-nav-parent-item h-more-item" ><a href="#" >More</a><ul class="b-nav__items-1"><li class="b-nav__item-1 b-nav__item-1--parent" ><a href="#" >More</a><ul class="b-nav__items-2"><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/about/?itm_medium=nav" >About Digital Trends</a></li><li class="b-nav__item-2" ><a href="https://www.themanual.com/" >The Manual</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/advertise-with-us/?itm_medium=nav" >Advertise with Us</a></li><li class="b-nav__item-2" ><a href="https://es.digitaltrends.com/" >DT en Español</a></li><li class="b-nav__item-2" ><a href="https://dtdesign.digitaltrends.com/" >Creative Resources</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/awards-we-offer/?itm_medium=nav" >Awards We Offer</a></li><li class="b-nav__item-2" ><a href="https://www.digitaltrends.com/press-room/?itm_medium=nav" >Press</a></li><li class="b-nav__item-2" ><a href="https://boards.greenhouse.io/digitaltrends" >Careers</a></li></ul></li><li class="b-nav__item-1 b-nav__item-1--parent social" ><a href="#" >Social</a><ul class="b-nav__items-2"><li class="b-nav__item-2 twitter" ><a href="https://twitter.com/digitaltrends" >Twitter</a></li><li class="b-nav__item-2 facebook" ><a href="https://www.facebook.com/DigitalTrends" >Facebook</a></li><li class="b-nav__item-2 instagram" ><a href="https://instagram.com/digitaltrends" >Instagram</a></li><li class="b-nav__item-2 linkedin" ><a href="https://www.linkedin.com/company/digitaltrends-com" >LinkedIn</a></li><li class="b-nav__item-2 pinterest" ><a href="https://pinterest.com/digitaltrends/" >Pinterest</a></li><li class="b-nav__item-2 rss" ><a href="https://www.digitaltrends.com/rss-home/?itm_medium=nav" >RSS</a></li><li class="b-nav__item-2 mail" ><a href="https://www.digitaltrends.com/newsletter/?itm_medium=nav" >Newsletter</a></li><li class="b-nav__item-2 youtube" ><a href="https://www.youtube.com/subscription_center?add_user=DigitalTrends" >YouTube</a></li></ul></li></ul></li>	</ul>

	<button class="b-nav__button b-nav__button--menu h-nav-menu-button">
		<span class="is-visually-hidden">
			Menu		</span>
	</button>
</header>

	<div class="b-sub">
		<ul class="b-sub__items-0 h-nav-sub-items">
			<li class="b-sub__item-0" ><a href="#" >Trending Stories:</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/news/coronavirus-survey-data-facebook-google/?itm_medium=subnav" >Coronavirus surveys</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/cars/oil-prices-negative-first-time/?itm_medium=subnav" >Oil Prices Crash</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/gaming/facebook-gaming-app-launch/?itm_medium=subnav" >Facebook releases gaming app</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/health-fitness/remdesivir-gilead-coronavirus-treatment/?itm_medium=subnav" >What is Remdesivir?</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/news/watch-these-virtual-concert-livestreams-during-your-social-distancing/?itm_medium=subnav" >Virtual Concerts in April</a></li><li class="b-sub__item-0" ><a href="https://www.digitaltrends.com/topic/work-from-home/?itm_medium=subnav" >Social Distancing Guide</a></li>		</ul>
	</div>

<script>
	(function() {
		var a = document.querySelector('.h-nav-container');
		var b = a.querySelector('.h-nav-items');
		var c = a.querySelector('.h-nav-logo');
		var f = function () {
			var space = b.getBoundingClientRect().left - c.getBoundingClientRect().right;

			if (space > 40) {
				a.classList.remove('is-small');
				a.classList.add('is-big');
			} else {
				a.classList.remove('is-big');
				a.classList.add('is-small');
			}

			if (space > 300) {
				a.classList.add('is-huge');
			} else {
				a.classList.remove('is-huge');
			}
		};
		window.addEventListener('resize', f, false);
		f();
		window.dtResizeNav = f;
	}());
</script>

	

<div class="b-page "  data-post-id="2483739" data-post-url="https://www.digitaltrends.com/dtdeals/best-buy-mobile-sale-galaxy-s20-google-pixel-4-iphone-xs/">
	<div class="b-page__inner">
		<div class="b-single b-page__single">
			<header class="b-headline b-single__headline" id="dt-post-title">
				<div class="b-headline__crumbs ">
					<ol itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a itemprop="item" href="https://www.digitaltrends.com/dtdeals/"><span itemprop="name">Deals</span></a><meta itemprop="position" content="1" /></li></ol>				</div>

				<div class="b-headline__note">Digital Trends may earn a commission when you buy through links on our site.</div>
				<h1 class="b-headline__title " itemprop="headline">
					Best Buy Mobile Sale: Galaxy S20, Google Pixel 4, iPhone XS in the discount bin				</h1>

				
				<div class="b-headline__meta ">
					
<cite class="b-byline b-headline__byline">
			<span class="b-byline__authors">
			By
							<a
					class="author url fn "
					href="https://www.digitaltrends.com/users/lucascoll/"
					rel="author"
				>
					Lucas Coll				</a>
									</span>
	
	<time
		class="b-byline__time date dtreviewed"
		datetime="2020-04-20T09:52:00-07:00"
	>
		April 20, 2020  9:52AM PST	</time>
</cite>

					

<div class="b-social b-social--rhythm  b-headline__social">
	<button
		class="b-social__button b-social__button--outbound h-share-it"
		data-template-id="dt-share-5e9e7f7d986ea"
		title="More sharing options"
	>
</div>

<script id="dt-share-5e9e7f7d986ea" type="text/template">
	<div class="b-modal">
		<div class="b-modal__inner b-modal__content">
			<div class="b-modal__title">
				Share			</div>

			<div class="b-social b-social--bleed b-modal__social">
									<button
						class="b-social__button b-social__button--facebook h-share-it"
						data-key="facebook"
						title="Share on Facebook"
					>
				
									<button
						class="b-social__button b-social__button--twitter h-share-it"
						data-key="twitter"
						title="Tweet this"
					>
				
				<button
					class="b-social__button b-social__button--linkedin h-share-it"
					data-key="linkedin"
					title="Share on LinkedIn"
				>

				<button
					class="b-social__button b-social__button--pinterest h-share-it"
					data-key="pinterest"
					title="Share on Pinterest"
				>

				<button
					class="b-social__button b-social__button--flipboard h-share-it"
					data-key="flipboard"
					title="Share on Flipboard"
				>

				<button
					class="b-social__button b-social__button--mail h-share-it"
					data-key="email"
					title="Email this"
				>
			</div>

			<button class="b-modal__close h-close">
				<span class="is-visually-hidden">
					Close				</span>
			</button>
		</div>
	</div>
</script>

				</div>
			</header>

			
			<article
				class="b-content b-single__content h-article-content "
				id="dt-post-content"
				itemid="post-content"
				itemprop="articleBody"
			>
				<p>Everybody knows that Best Buy is a popular outlet for computers, TVs, gaming consoles, and more, but it&#8217;s also one of the best places to find <a href="https://www.digitaltrends.com/dtdeals/best-smartphone-deals/">smartphone deals</a>. That&#8217;s due in large part to the fact that, whereas most other retailers typically sell carrier-unlocked devices, Best Buy offers both unlocked mobile deals along with the latest discounts, rebates, and exclusive offers from America&#8217;s biggest nationwide service providers. Right now, Best Buy is running a limited-time sale on a few of the top flagship devices on the market in 2020 including the <span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/iphone/shop-iphone-xs-iphone-xs-max/pcmcat1536780736987.c?id=pcmcat1536780736987" data-title="iPhone XS" data-cta="iPhone XS">iPhone XS</span>, <span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/google/learn-about-google-pixel-4/pcmcat1566430029496.c?id=pcmcat1566430029496" data-title="Google Pixel 4" data-cta="Google Pixel 4">Google Pixel 4</span>, and <span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/samsung-store/learn-about-samsung-galaxy-s20/pcmcat1578334926909.c?id=pcmcat1578334926909" data-title="Samsung Galaxy S20" data-cta="Samsung Galaxy S20">Samsung Galaxy S20</span>, as well as some <span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/clp-cell-phones/mobile-phone-accessories-coupon-offer/pcmcat1564414958327.c?id=pcmcat1564414958327" data-title="deals on must-have accessories" data-cta="deals on must-have accessories">deals on must-have accessories</span>, and we&#8217;ve rounded up the different offers below. Act fast, though &#8212; none of these mobile deals are scheduled to last beyond the end of May, and a few of them expire much sooner than that.</p>
<h2><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/iphone/shop-iphone-xs-iphone-xs-max/pcmcat1536780736987.c?id=pcmcat1536780736987" data-title="iPhone XS &amp; XS Max" data-cta="iPhone XS &amp; XS Max">iPhone XS &amp; XS Max</span> &#8212; Save up to $350</h2>
<figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn7.digitaltrends.com/image/digitaltrends/apple-iphone-xs-review-5-3-2-2-720x720.jpg" onerror="dti_load_error(this)" class=" size-large wp-image-2430855 dt-lazy-load dt-lazy-pending" alt></figure>
<p>The iPhone XS and XS Max were Apple flagships for 2018, succeeding the iPhone 8 and 8 Plus. Upon release, <a href="https://www.digitaltrends.com/cell-phone-reviews/apple-iphone-xs-review/">our review team called the iPhone XS a &#8220;masterpiece&#8221;</a> and named it the best Apple flagship yet. We also thoroughly enjoyed the gorgeous 6.5-inch display on the iPhone XS Max, which is a great option if you want a bit more screen real estate (the touchscreen on the standard XS measures in at 5.8 inches). Both phones feature the same gorgeous OLED display technology, superb all-day battery life, and smooth performance, with all the Apple polish that iPhone fans are already well familiar with.</p>
<p>If you&#8217;re after one of these still-awesome flagships and don&#8217;t want to shell out the cash for the newer iPhone 11, then Best Buy is offering the iPhone XS and XS Max for up to $350 off (reflected in reduced monthly payments for the phone) with qualifying carrier activation until Thursday, April 23.</p>
<p style="text-align: center;"><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="button-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/iphone/shop-iphone-xs-iphone-xs-max/pcmcat1536780736987.c?id=pcmcat1536780736987" data-title="" data-cta=""></span></p>
<h2><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/google/learn-about-google-pixel-4/pcmcat1566430029496.c?id=pcmcat1566430029496" data-title="Google Pixel 4 &amp; Pixel 4 XL" data-cta="Google Pixel 4 &amp; Pixel 4 XL">Google Pixel 4 &amp; Pixel 4 XL</span> &#8212; Save up to $350</h2>
<figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn7.digitaltrends.com/image/digitaltrends/pixel-4-xl-screen-2-720x720.jpg" onerror="dti_load_error(this)" class=" size-large wp-image-2431319 dt-lazy-load dt-lazy-pending" alt></figure>
<p>Google is the name behind Android, the world&#8217;s most popular mobile OS, so it&#8217;s no huge shock that its Pixel phones offer what might be the best Android experience you can buy today. The Pixel 4 is the latest iteration of Google&#8217;s signature flagship, and &#8212; mediocre battery life notwithstanding &#8212; <a href="https://www.digitaltrends.com/cell-phone-reviews/google-pixel-4-review/">it&#8217;s fantastic</a>. Its cutting-edge camera module set a new industry standard with other makers like (Apple and Samsung now copying the design), and even if you need to keep a charger handy, the Pixel 4 and <a href="https://www.digitaltrends.com/cell-phone-reviews/google-pixel-4-xl-review/">Pixel 4 XL</a> still offer excellent performance paired with sharp and vibrant touchscreens.</p>
<p>The Google Pixel 4 and 4 XL are also quite reasonably priced relative to other flagships which are now commonly launching with $1,000 starting prices, but this smartphone deal from Best Buy lets you take $300 off either of these unlocked devices plus an additional $50 off if you activate with a carrier when you buy. This offer lasts until Friday, May 1.</p>
<p style="text-align: center;"><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="button-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/google/learn-about-google-pixel-4/pcmcat1566430029496.c?id=pcmcat1566430029496" data-title="" data-cta=""></span></p>
<h2><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/promo/greatcall-lively-mobile-plus" data-title="GreatCall Jitterbug" data-cta="GreatCall Jitterbug">GreatCall Jitterbug</span> &#8212; 25% off</h2>
<figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/jitterbug-flip_1-720x720.jpg" onerror="dti_load_error(this)" class=" size-large wp-image-2344459 dt-lazy-load dt-lazy-pending" alt="Jitterbug Flip"></figure>
<p>They&#8217;re not flagships, but the Jitterbug phones from lesser-known brand GreatCall are an excellent alternative to touchscreen smartphones for anybody who misses the glory days of the flip phone. The standard Jitterbug folding phone is an old-school but well-made modern device sporting a traditional tactile keypad (with large, easy-to-read characters) and a 3.2-inch display. The software keeps things simple, too, with a straightforward and non-cluttered interface that&#8217;s a breeze to use. The Jitterbug flip phones are designed with seniors in mind, but they&#8217;re also a good choice for kids, work phones, and anybody suffering from smartphone fatigue &#8212; although if you want that touch display, then the Jitterbug Smart2 is a smartphone that also offers a clean, simple, user-friendly experience.</p>
<p>These GreatCall Jitterbug phones are discounted by 25% through Sunday, May 3. The Lively Mobile+ wearable medical alert device is also marked down as part of the Best Buy mobile sale.</p>
<p style="text-align: center;"><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="button-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/promo/greatcall-lively-mobile-plus" data-title="" data-cta=""></span></p>
<h2><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/samsung-store/learn-about-samsung-galaxy-s20/pcmcat1578334926909.c?id=pcmcat1578334926909" data-title="Samsung Galaxy S20, S20 Plus, &amp; S20 Ultra" data-cta="Samsung Galaxy S20, S20 Plus, &amp; S20 Ultra">Samsung Galaxy S20, S20 Plus, &amp; S20 Ultra</span> &#8212; Save up to $300</h2>
<figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/samsung-galaxy-s20-ultra-hands-on-7-of-11-2-720x720.jpg" onerror="dti_load_error(this)" class=" size-large wp-image-2452263 dt-lazy-load dt-lazy-pending" alt="samsung-galaxy-s20-ultra-hands-on"></figure>
<p>Last year we saw the release of the Samsung Galaxy S10, marking the 10th anniversary of the Galaxy flagship smartphone line. This year, Samsung revealed <a href="https://www.digitaltrends.com/mobile/samsung-galaxy-s20-galaxy-s20-plus-hands-on-features-price-photos-release-date/">the all-new Galaxy S20 series</a> (named for the year 2020), and while the new models don&#8217;t re-invent the wheel, they feature everything we love about the Galaxy line and bear some notable improvements &#8212; the most noteworthy of which is 5G capabilities. The excellent hardware of the Galaxy S20 makes Samsung&#8217;s new flagships arguably the best choice for anybody looking for a smartphone to use on a 5G network. Along with that high-speed LTE connectivity, the Galaxy S20, <a href="https://www.digitaltrends.com/cell-phone-reviews/samsung-galaxy-s20-plus-review/">Galaxy S20 Plus</a>, and <a href="https://www.digitaltrends.com/mobile/samsung-galaxy-s20-ultra-hands-on-features-price-photos-release-date/">Galaxy S20 Ultra</a> all boast excellent built quality, eye-pleasing 120Hz touchscreens, great camera modules, and nice (if fairly standard) aesthetics.</p>
<p>Until Sunday, May 17, Best Buy is letting you save up to $300 on the Samsung Galaxy S20, S20 Plus, or premium S20 Ultra with a qualifying activation.</p>
<p style="text-align: center;"><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="button-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/samsung-store/learn-about-samsung-galaxy-s20/pcmcat1578334926909.c?id=pcmcat1578334926909" data-title="" data-cta=""></span></p>
<h2><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="textlink-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/clp-cell-phones/mobile-phone-accessories-coupon-offer/pcmcat1564414958327.c?id=pcmcat1564414958327" data-title="Mobile Accessories" data-cta="Mobile Accessories">Mobile Accessories</span> &#8212; 20% off with promo code</h2>
<figure class="aligncenter"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn3.digitaltrends.com/image/digitaltrends/blackberry-key2-popsocket-720x720.jpg" onerror="dti_load_error(this)" class=" size-large wp-image-1398456 dt-lazy-load dt-lazy-pending" alt="Andy Boxall/Digitaltrends.com"></figure>
<p>Naturally, once you score that shiny new smartphone, the next step is to grab some must-have accessories for it. Best Buy has you covered there as well: Until the end of May, you can use the checkout code <strong>20PERCENTOFF</strong><strong> </strong>to get a nice 20% discount on select cell phone gadgets such as wireless charging pads, phone chargers and cables, tripods, gimbal stabilizers, selfie sticks, cases, and more. Brands included in this sale OtterBox, LifeProof, Speck, and PopSockets, to name just a few.</p>
<p style="text-align: center;"><span data-placement="deeplink" data-deeplink="1" class="dtcc-deeplink" data-cloudcity="1" data-align="" data-type="button-deeplink" data-merchant="5d7690f161b3f3001859bd59" data-url="https://www.bestbuy.com/site/clp-cell-phones/mobile-phone-accessories-coupon-offer/pcmcat1564414958327.c?id=pcmcat1564414958327" data-title="" data-cta=""></span></p>
<div class='m-deal-disclaimer'>We strive to help our readers find the best deals on quality products and services, and we choose what we cover carefully and independently. The prices, details, and availability of the products and deals in this post may be subject to change at anytime. Be sure to check that they are still in effect before making a purchase.<br><br>Digital Trends may earn commission on products purchased through our links, which supports the work we do for our readers.</div>
			<h4 class='h-editors-recs-title'>
			Editors' Recommendations		</h4>

		<ul class="h-editors-recs">
							<li>
					<a href="https://www.digitaltrends.com/dtdeals/best-smartphone-deals/?itm_medium=editors">
						Best smartphone deals for April 2020: iPhone, Samsung, and Google Pixel					</a>
				</li>
							<li>
					<a href="https://www.digitaltrends.com/dtdeals/best-samsung-galaxy-deals/?itm_medium=editors">
						The best Samsung Galaxy deals for April 2020					</a>
				</li>
							<li>
					<a href="https://www.digitaltrends.com/dtdeals/best-iphone-deals/?itm_medium=editors">
						The best Apple iPhone deals for April 2020					</a>
				</li>
							<li>
					<a href="https://www.digitaltrends.com/dtdeals/best-tablet-deals/?itm_medium=editors">
						The best iPad, Samsung Galaxy, Fire, and Pixel tablet deals for April 2020					</a>
				</li>
							<li>
					<a href="https://www.digitaltrends.com/dtdeals/best-samsung-galaxy-tab-deals/?itm_medium=editors">
						The best cheap Samsung Galaxy Tab deals for April 2020					</a>
				</li>
					</ul>
	
				<span id="publisher-md" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
					<span itemprop="url" itemtype="https://schema.org/Url" content="https://www.digitaltrends.com">
					<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
						<meta itemprop="url" content="https://cdn.dtcn.com/dt/dt-logo-small.png">
						<meta itemprop="width" content="0">
						<meta itemprop="height" content="0">
					</span>

					<meta itemprop="name" content="Digital Trends">
				</span>

				<span itemprop='image' itemscope itemtype='https://schema.org/ImageObject'>
					<meta itemprop='url' content='https://icdn2.digitaltrends.com/image/digitaltrends/pixel-4-competitors.jpg'>
				</span>
			</article>

			
					<script>
						(function () {
							var slides = Array.prototype.slice.call(document.querySelectorAll('.h-dt-slide'));
							if (slides.length) {
								slides[0].classList.add('is-current');
							}
						})()
					</script>
				
			
<section class="b-grid b-single__grid">
	
<div class="b-flyer b-flyer--2-6  b-grid__flyer  b-grid__cols2  b-grid__rows6" >
	<div class="b-meta b-meta--large b-flyer__meta ">
					<h3 class="b-meta__title b-meta--large__title dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/mobile/best-android-phones/" class="b-flyer__hot" target="">					The best Android phones for 2020				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T16:13:16-07:00" title="4.20.20 4:13pm" pubdate>5 hours ago</time></span> 			</div>
			</div>

			<div class="b-flyer__image b-flyer--2-6__image">
							<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn4.digitaltrends.com/image/digitaltrends/note-10-versus-pixel-3-xl-610x380-c.jpg" class="attachment-width=610&amp;height=380&amp;crop=1 size-width=610&amp;height=380&amp;crop=1 wp-image-2377521 dt-lazy-load dt-lazy-pending" alt="samsung galaxy note 10 plus vs google pixel 3 xl versus">			
					</div>
	</div>

<div class="b-brief b-brief--1-6  b-grid__brief  b-grid__cols1  b-grid__rows6" >
	<div class="b-meta b-brief__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-tablet-deals/" class="b-brief__hot" target="">					The best iPad, Samsung Galaxy, Fire, and Pixel tablet deals for April 2020				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T06:18:32-07:00" title="4.20.20 6:18am" pubdate>15 hours ago</time></span> 			</div>
			</div>

			<div class="b-brief__image b-brief--1-6__image">
							<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/apple-ipad-pro-10-5-review-screen-angle-1-3-2-300x250-c.jpg" class="attachment-width=300&amp;height=250&amp;crop=1 size-width=300&amp;height=250&amp;crop=1 wp-image-2474096 dt-lazy-load dt-lazy-pending" alt="apple ipad air pro deals best buy macmall work from home sale 10 5 review screen angle 1 3 768x768">			
					</div>
	</div>

<div class="b-brief b-brief--1-6  b-grid__brief  b-grid__cols1  b-grid__rows6" >
	<div class="b-meta b-brief__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-iphone-deals/" class="b-brief__hot" target="">					The best Apple iPhone deals for April 2020				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-17T23:17:56-07:00" title="4.17.20 11:17pm" pubdate>2 days ago</time></span> 			</div>
			</div>

			<div class="b-brief__image b-brief--1-6__image">
							<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn9.digitaltrends.com/image/digitaltrends/iphone-2019-2-300x250-c.jpg" class="attachment-width=300&amp;height=250&amp;crop=1 size-width=300&amp;height=250&amp;crop=1 wp-image-2345840 dt-lazy-load dt-lazy-pending" alt="best iphone deals 2019">			
					</div>
	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/dtdeals/best-smartphone-deals/" class="b-snippet__hot" target="">					Best smartphone deals for April 2020: iPhone, Samsung, and Google Pixel				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-16T00:30:23-07:00" title="4.16.20 12:30am" pubdate>4 days ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn3.digitaltrends.com/image/digitaltrends/note-10-plusoneplus-7t-pixel-4-xl-iphone-11-pro-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-2406677 dt-lazy-load dt-lazy-pending" alt="note 10 plus,oneplus 7t, pixel 4 xl, iphone 11 pro">		</div>
	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/dtdeals/best-headphone-deals/" class="b-snippet__hot" target="">					The best wireless headphone deals for April 2020				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T00:43:35-07:00" title="4.20.20 12:43am" pubdate>21 hours ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn6.digitaltrends.com/image/digitaltrends/sony-wh-1000xm2-lifestyle-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-1321136 dt-lazy-load dt-lazy-pending" alt="best headphones sony sh-1000mx2">		</div>
	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/dtdeals/best-qled-tv-deals/" class="b-snippet__hot" target="">					The best cheap QLED TV deals for April 2020: Samsung and Vizio				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T00:46:36-07:00" title="4.20.20 12:46am" pubdate>21 hours ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/samsung-49-inch-q60-qled-tv-2-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-2417594 dt-lazy-load dt-lazy-pending" alt="55 inch samsung uhd 7 series q60 qled 4k tvs amazon deal 49 tv 720x720">		</div>
	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-oled-tv-deals/" class="b-flyer__hot" target="">					The best cheap OLED TV deals for April 2020: LG and Sony				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T00:51:14-07:00" title="4.20.20 12:51am" pubdate>21 hours ago</time></span> 			</div>
			</div>

	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-walmart-tv-deals/" class="b-flyer__hot" target="">					The best Walmart TV deals for April 2020: 4K TVs, QLED TVs, and OLED TVs				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T00:53:36-07:00" title="4.20.20 12:53am" pubdate>21 hours ago</time></span> 			</div>
			</div>

	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-cheap-soundbar-deals/" class="b-flyer__hot" target="">					The best soundbar deals for April 2020: Bose, Samsung, Sonos				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T00:56:14-07:00" title="4.20.20 12:56am" pubdate>21 hours ago</time></span> 			</div>
			</div>

	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/best-wireless-keyboard-deals/" class="b-flyer__hot" target="">					The best wireless keyboard deals for April 2020: Apple, Corsair, Logitech				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T01:00:12-07:00" title="4.20.20 1:00am" pubdate>21 hours ago</time></span> 			</div>
			</div>

	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/dtdeals/best-wireless-mouse-deals/" class="b-snippet__hot" target="">					The best cheap wireless mouse deals for April 2020				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T01:07:40-07:00" title="4.20.20 1:07am" pubdate>20 hours ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/logitech-mx-master-mouse-hero1-2-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-2459546 dt-lazy-load dt-lazy-pending" alt="Logitech MX Master">		</div>
	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/dtdeals/best-amazon-echo-deals/" class="b-snippet__hot" target="">					These are the best Amazon Echo device deals for April 2020				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T05:19:21-07:00" title="4.20.20 5:19am" pubdate>16 hours ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/amazon-echo-show-8-review-16-of-17-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-2426326 dt-lazy-load dt-lazy-pending" alt="amazon echo show 8 review 16 of 17">		</div>
	</div>

<div class="b-snippet b-snippet--2-2  b-grid__snippet  b-grid__cols2  b-grid__rows2" >
	<div class="b-meta b-snippet__meta ">
					<h3 class="b-meta__title dt-clamp dt-clamp-2">
				<a href="https://www.digitaltrends.com/home/best-dyson-deals/" class="b-snippet__hot" target="">					The best Dyson deals and sales for April  2020: Vacuums and Fans				</a>			</h3>
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T07:53:49-07:00" title="4.20.20 7:53am" pubdate>14 hours ago</time></span> 			</div>
			</div>

			<div class="b-snippet__image b-snippet--2-2__image">
			<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-dt-lazy-src="https://icdn2.digitaltrends.com/image/digitaltrends/dyson-v11-torque-drive-2-resized-120x120-c.jpg" class="attachment-width=120&amp;height=120&amp;crop=1 size-width=120&amp;height=120&amp;crop=1 wp-image-2434392 dt-lazy-load dt-lazy-pending" alt="dyson v11 torque vacuum deal drive 2 resized">		</div>
	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/home/best-coffee-maker-deals/" class="b-flyer__hot" target="">					The best coffee maker deals for April 2020: Keurig, Ninja, Breville, and more				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T08:37:10-07:00" title="4.20.20 8:37am" pubdate>13 hours ago</time></span> 			</div>
			</div>

	</div>

<div class="b-flyer b-flyer--1-4  b-grid__flyer  b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="https://www.digitaltrends.com/dtdeals/55-inch-lg-samsung-tcl-toshiba-4k-tv-deals-best-buy-spring-sale/" class="b-flyer__hot" target="">					Cheap 55-inch 4K TVs: LG, Samsung, TCL, Toshiba on sale from only $280				</a>			</h3>
		
		
		
					<div class="b-meta__labels">
				<span><time datetime="2020-04-20T09:05:12-07:00" title="4.20.20 9:05am" pubdate>13 hours ago</time></span> 			</div>
			</div>

	</div>
</section>



			<aside class="b-sidebar b-single__sidebar h-sidebar"></aside>
		</div>
	</div>
</div>



		<footer class="b-foot">
			<div class="b-foot__inner">
				<div class="b-foot__logo">
											<a href="https://www.digitaltrends.com">
							<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 231 45" width="231" height="45" alt="Digital Trends">
	<path fill="#fff" d="M56.9,17.42v9.9h2.87c3.06,0,5.05-2.06,5.05-4.91v-0.04c0-2.85-2-4.95-5.05-4.95L56.9,17.42L56.9,17.42z M54.34,15.09h5.43c4.57,0,7.73,3.14,7.73,7.24v0.04c0,4.1-3.16,7.28-7.73,7.28h-5.43V15.09z"/>
	<path fill="#fff" d="M70.75,15.09h2.56v14.55h-2.56V15.09z"/>
	<path fill="#fff" d="M76.55,22.41v-0.04c0-4.08,3.12-7.53,7.51-7.53c2.54,0,4.1,0.71,5.59,1.98l-1.62,1.93 c-1.12-0.94-2.22-1.54-4.08-1.54c-2.68,0-4.72,2.33-4.72,5.11v0.04c0,2.99,1.98,5.2,4.95,5.2c1.37,0,2.62-0.44,3.51-1.1v-2.7h-3.72 v-2.25h6.2v6.11c-1.43,1.23-3.49,2.27-6.07,2.27C79.54,29.9,76.55,26.65,76.55,22.41z"/>
	<path fill="#fff" d="M93.64,15.09h2.56v14.55h-2.56V15.09z"/>
	<path fill="#fff" d="M103.64,17.46H99v-2.37h11.83v2.37h-4.64v12.18h-2.56V17.46H103.64z"/>
	<path fill="#fff" d="M120.46,23.87l-2.52-5.82l-2.49,5.82H120.46z M116.8,14.99h2.37l6.4,14.66h-2.7l-1.48-3.51h-6.88l-1.5,3.51 h-2.62L116.8,14.99z"/>
	<path fill="#fff" d="M128.07,15.09h2.56v12.23h7.65v2.33h-10.21V15.09z"/>
	<polygon fill="#fff" points="147.2,18.41 142.83,18.41 142.83,15.09 155.32,15.09 155.32,18.41 150.93,18.41 150.93,29.65  147.2,29.65"/>
	<path fill="#fff" d="M164.07,22.11c1.43,0,2.27-0.73,2.27-1.85v-0.04c0-1.24-0.89-1.87-2.31-1.87h-2.86v3.76H164.07z M157.45,15.09 h6.8c2.08,0,3.58,0.56,4.55,1.53c0.84,0.84,1.27,1.96,1.27,3.37v0.04c0,2.28-1.22,3.76-3.04,4.5l3.5,5.12h-4.3l-3-4.5h-2.06v4.5 h-3.72L157.45,15.09L157.45,15.09z"/>
	<polygon fill="#fff" points="172.55,15.09 183.98,15.09 183.98,18.29 176.24,18.29 176.24,20.79 183.18,20.79 183.18,23.85  176.24,23.85 176.24,26.44 184.09,26.44 184.09,29.65 172.55,29.65"/>
	<polygon fill="#fff" points="186.57,15.09 190.03,15.09 196.33,23.26 196.33,15.09 200.01,15.09 200.01,29.65 196.79,29.65  190.25,21.19 190.25,29.65 186.57,29.65"/>
	<path fill="#fff" d="M206.77,18.4v7.93h1.95c2.5,0,4.17-1.49,4.17-3.93v-0.04c0-2.42-1.66-3.96-4.17-3.96H206.77z M203.05,15.09 h5.65c4.95,0,8.02,3.05,8.02,7.21v0.04c0,4.16-3.1,7.3-8.07,7.3h-5.6V15.09z"/>
	<path fill="#fff" d="M217.94,27.5l2.11-2.53c1.4,1.12,2.9,1.76,4.58,1.76c1.18,0,1.84-0.43,1.84-1.14v-0.04 c0-0.69-0.48-1.05-2.65-1.58c-3.03-0.74-5.24-1.57-5.24-4.52v-0.04c0-2.68,2.13-4.56,5.43-4.56c2.34,0,4.23,0.67,5.77,1.9 l-1.88,2.68c-1.32-0.93-2.7-1.43-3.97-1.43c-1.07,0-1.61,0.46-1.61,1.06v0.04c0,0.78,0.54,1.08,2.76,1.6 c3.19,0.75,5.11,1.82,5.11,4.47v0.04c0,2.94-2.29,4.66-5.68,4.66C222.08,29.88,219.73,29.09,217.94,27.5z"/>
	<rect x="0.11" y="0.11" fill="#fff" width="44.78" height="44.77"/>
	<path fill="#0094e5" d="M0,0v45h45V0H0z M8.44,26.44h5.62v4.5H8.44V26.44z M18.56,36.56H8.44v-4.5h10.12V36.56z M36.56,25.31H25.31 v11.25h-5.62V25.31H8.44v-5.62h11.25l0,0l0,0V8.44h5.62v11.25h11.25V25.31z"/>
</svg>
						</a>
									</div>

				<div class="b-foot__blurb">
					<p><strong>Upgrade your lifestyle</strong><br><br>Digital Trends helps readers keep tabs on the fast-paced world of tech with all the latest news, fun product reviews, insightful editorials, and one-of-a-kind sneak peeks.<br><br>Digital Trends may earn a commission when you buy through links on our site.</p>

					<p>Copyright &copy;2020 Designtechnica Corporation. All rights reserved.</p>

								<a href='https://itunes.apple.com/us/app/digital-trends/id500266645?mt=8' target="_blank" rel="nofollow" class="b-foot__app">
				<img class="dt-lazy-load dt-lazy-pending dt-lazy-no-scale" data-dt-lazy-src="https://www.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/images/app-store.jpg" alt="iPhone app on the App Store">
			</a>

			<a href='https://play.google.com/store/apps/details?id=tv.accedo.ott.flow.digital.trends' target="_blank" rel="nofollow" class="b-foot__app">
				<img class="dt-lazy-load dt-lazy-pending dt-lazy-no-scale" data-dt-lazy-src="https://www.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/images/google-play.jpg" alt="Android app on Google Play">
			</a>
						</div>

				<ul id="menu-2019-social" class="b-foot__social"><li id="menu-item-2355717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2355717"><a href="#">Add Us To Your Social Channels</a>
<ul class="sub-menu">
	<li id="menu-item-2355718" class="facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-2355718"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/DigitalTrends">Facebook</a></li>
	<li id="menu-item-2355719" class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-2355719"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/digitaltrends">Twitter</a></li>
	<li id="menu-item-2355720" class="instagram menu-item menu-item-type-custom menu-item-object-custom menu-item-2355720"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/digitaltrends/">Instragram</a></li>
	<li id="menu-item-2355721" class="linkedin menu-item menu-item-type-custom menu-item-object-custom menu-item-2355721"><a target="_blank" rel="noopener noreferrer" href="https://www.linkedin.com/company/digitaltrends-com/">LinkedIn</a></li>
	<li id="menu-item-2355722" class="pinterest menu-item menu-item-type-custom menu-item-object-custom menu-item-2355722"><a target="_blank" rel="noopener noreferrer" href="https://www.pinterest.com/digitaltrends/">Pinterest</a></li>
	<li id="menu-item-2355723" class="youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-2355723"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UC8wXC0ZCfGt3HaVLy_fdTQw?sub_confirmation=1">YouTube</a></li>
	<li id="menu-item-2355724" class="rss menu-item menu-item-type-post_type menu-item-object-page menu-item-2355724"><a href="https://www.digitaltrends.com/rss-home/">RSS Home</a></li>
</ul>
</li>
<li id="menu-item-2361044" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2361044"><a href="#">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-2361045" class="subscribe menu-item menu-item-type-post_type menu-item-object-page menu-item-2361045"><a href="https://www.digitaltrends.com/newsletter/">Newsletter Landing</a></li>
</ul>
</li>
</ul>
				<ul id="menu-2019-footer" class="b-foot__menu"><li id="menu-item-2355732" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2355732"><a href="#">Must Reads</a>
<ul class="sub-menu">
	<li id="menu-item-2355736" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2355736"><a href="https://www.digitaltrends.com/movies/best-movies-on-netflix/?itm_medium=footer">Best Movies on Netflix</a></li>
	<li id="menu-item-2364792" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364792"><a href="https://www.digitaltrends.com/movies/best-shows-on-netflix/?itm_medium=footer">Best Shows on Netflix</a></li>
	<li id="menu-item-2364752" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364752"><a href="https://www.digitaltrends.com/movies/best-shows-on-hulu/?itm_medium=footer">Best Shows on Hulu</a></li>
	<li id="menu-item-2364751" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364751"><a href="https://www.digitaltrends.com/movies/best-movies-on-hulu/?itm_medium=footer">Best Movies on Hulu</a></li>
	<li id="menu-item-2364753" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364753"><a href="https://www.digitaltrends.com/movies/best-shows-on-amazon-prime/?itm_medium=footer">Best Shows on Amazon Prime</a></li>
	<li id="menu-item-2364793" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364793"><a href="https://www.digitaltrends.com/movies/best-movies-on-amazon-prime/?itm_medium=footer">Best Movies on Amazon Prime</a></li>
	<li id="menu-item-2364754" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364754"><a href="https://www.digitaltrends.com/mobile/best-iphone-games/?itm_medium=footer">Best iPhone Games</a></li>
	<li id="menu-item-2364755" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2364755"><a href="https://www.digitaltrends.com/mobile/best-android-games/?itm_medium=footer">Best Android Games</a></li>
	<li id="menu-item-2418032" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-2418032"><a href="https://www.digitaltrends.com/business/best-tech-jobs/?itm_medium=footer">Best Tech Jobs</a></li>
	<li id="menu-item-2455855" class="menu-item menu-item-type-post_type menu-item-object-prod_guide menu-item-2455855"><a href="https://www.digitaltrends.com/product-guide/staples-back-to-business/?itm_medium=footer">Office Essentials</a></li>
</ul>
</li>
<li id="menu-item-2364773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2364773"><a href="#">Popular Downloads</a>
<ul class="sub-menu">
	<li id="menu-item-2364774" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364774"><a href="https://downloads.digitaltrends.com/fortnite/windows">Download Fortnite</a></li>
	<li id="menu-item-2364775" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364775"><a href="https://downloads.digitaltrends.com/skype/windows">Download Skype</a></li>
	<li id="menu-item-2364776" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364776"><a href="https://downloads.digitaltrends.com/winrar/windows">Download Winrar</a></li>
	<li id="menu-item-2364777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364777"><a href="https://downloads.digitaltrends.com/netflix/android">Download Netflix for Android</a></li>
	<li id="menu-item-2364778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364778"><a href="https://downloads.digitaltrends.com/spotify/android">Download Spotify for Android</a></li>
	<li id="menu-item-2364779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364779"><a href="https://downloads.digitaltrends.com/windows/games">Download PC games</a></li>
	<li id="menu-item-2371398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2371398"><a href="https://downloads.digitaltrends.com/">Downloads for Windows</a></li>
	<li id="menu-item-2371399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2371399"><a href="https://downloads.digitaltrends.com/mac">Downloads for Mac</a></li>
	<li id="menu-item-2371400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2371400"><a href="https://downloads.digitaltrends.com/android">Downloads for Android</a></li>
</ul>
</li>
<li id="menu-item-2355734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2355734"><a href="#">Who We Are</a>
<ul class="sub-menu">
	<li id="menu-item-2403678" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2403678"><a href="https://www.digitaltrends.com/about/?itm_medium=footer">About</a></li>
	<li id="menu-item-2411207" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2411207"><a href="https://www.digitaltrends.com/company-contacts/?itm_medium=footer">Contact Us</a></li>
	<li id="menu-item-2411256" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2411256"><a href="https://www.digitaltrends.com/privacy-policy/?itm_medium=footer">Privacy Policy</a></li>
	<li id="menu-item-2411273" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2411273"><a href="https://www.digitaltrends.com/terms-of-use/?itm_medium=footer">Terms of Use</a></li>
	<li id="menu-item-2463019" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2463019"><a href="https://www.digitaltrends.com/do-not-sell-my-info/?itm_medium=footer">Do Not Sell My Info</a></li>
	<li id="menu-item-2411288" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2411288"><a href="https://www.digitaltrends.com/corrections/?itm_medium=footer">Corrections</a></li>
	<li id="menu-item-2364786" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364786"><a href="https://boards.greenhouse.io/digitaltrends">Careers</a></li>
	<li id="menu-item-2364787" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364787"><a href="https://es.digitaltrends.com/">DT Español</a></li>
	<li id="menu-item-2364788" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2364788"><a href="https://www.themanual.com/">The Manual</a></li>
	<li id="menu-item-2463236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2463236"><a href="https://theangle.digitaltrends.com/">The Angle</a></li>
	<li id="menu-item-2411289" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2411289"><a href="https://www.digitaltrends.com/podcasts/?itm_medium=footer">Podcasts</a></li>
	<li id="menu-item-2364790" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2364790"><a href="https://www.digitaltrends.com/giveaways/?itm_medium=footer">Giveaways</a></li>
	<li id="menu-item-2404115" class="menu-item menu-item-type-post_type menu-item-object-topic menu-item-2404115"><a href="https://www.digitaltrends.com/advertise-with-us/?itm_medium=footer">Advertise with Us</a></li>
</ul>
</li>
</ul>			</div>
		</footer>

		
			<script>
				(function() {
					window.dtadsKeyvals = {"tags":["android","deals","google-pixel-4","iphone","iphone-xs","iphone-xs-max"],"cat":["android","apple","dtdeals","mobile"],"supports":["skin"],"aid":2483739};
					window.dtadsSlotTypes = {"atn":{"class":"dtads-slot-atn","sizes":[[2560,256],[970,250],[728,90],"fluid"],"keyvals":{"loc":"atn"}},"atn-tablet":{"class":"dtads-slot-atn-tablet","sizes":[[728,90],[728,230],"fluid"],"keyvals":{"loc":"atn"}},"atn-mobile":{"class":"dtads-slot-atn-mobile","sizes":[[320,50],[320,100],[480,90],"fluid"],"keyvals":{"loc":"atn"}},"hub":{"class":"dtads-slot-hub","sizes":[[2560,450],[970,250],[728,90],"fluid"],"preRenderCollapse":true,"refreshLocked":true,"keyvals":{"loc":"hub"}},"hub-mobile":{"class":"dtads-slot-hub-mobile","sizes":[[2560,450],[320,250],[300,250],"fluid"],"preRenderCollapse":true,"keyvals":{"loc":"hub"}},"out-of-page":{"class":"dtads-out-of-page","refreshLocked":true},"leaderboard":{"class":"dtads-slot-leaderboard","sizes":[[728,90],[950,250],[970,66],[970,90],[970,250],[970,418],[970,200],[940,230],[970,300],"fluid"],"keyvals":{"loc":"lb"}},"leaderboard-tablet":{"class":"dtads-slot-leaderboard-tablet","sizes":[[728,90],[728,230],"fluid"],"keyvals":{"loc":"lb"}},"leaderboard-mobile":{"class":"dtads-slot-leaderboard-mobile","sizes":[[320,50],[320,100],"fluid"],"keyvals":{"loc":"lb"}},"leaderboard-limited":{"class":"dtads-slot-leaderboard-limited","sizes":[[728,90],"fluid"],"keyvals":{"loc":"lb"}},"board":{"class":"dtads-slot-board","sizes":[[728,90],"fluid"]},"mpu":{"class":"dtads-slot-mpu","sizes":[[300,250],"fluid"]},"mpu_sticky":{"class":"dtads-slot-mpu-sticky","sizes":[[300,250],"fluid"]},"mpu_sticky_variable":{"class":"dtads-slot-mpu-sticky-variable","sizes":[[300,250],[300,600],"fluid"],"keyvals":{"loc":"sb"}},"halfpage":{"class":"dtads-slot-half","sizes":[[300,250],[300,600],"fluid"]},"mp":{"sizes":[970,600],"keyvals":{"refreshLocked":true},"class":"dtads-slot-mp"}};
					window.dtadsPrebid = {"desktop":{"enabled":1,"timeout":2000},"tablet":{"enabled":1,"timeout":2000},"mobile":{"enabled":1,"timeout":2000},"apstagId":3045,"nobidId":21860941703};
					window.dtadsInjector = {"desktop":0.80000000000000004,"mobile":0.94999999999999996};

					window.dtadsLazy = {"desktop":{"enabled":1,"threshold":650},"tablet":{"enabled":1,"threshold":450},"mobile":{"enabled":1,"threshold":250}};
					window.dtadsRefresh = {
						interval: 29 * 1000,
						timeout: 500 * 1000,
						lock: 14 * 1000,
					};

					console.log('DTAds Config', {
						dtadsKeyvals: window.dtadsKeyvals,
						dtadsSlotTypes: window.dtadsSlotTypes,
						dtadsLazy: window.dtadsLazy,
						dtadsRefresh: window.dtadsRefresh,
						dtadsPrebid: window.dtadsPrebid,
						dtadsInjector: window.dtadsInjector,
					});
				}());
			</script>

						<script>
				(function() {
					'use strict';

					var stage = 1;
					var options = {"permutive":{"project_id":"a49795fb-5053-49b1-8c42-32306718829e","api_key":"68c1920c-2250-4d24-87bf-237c1739c034"},"dtvideos":{"brightcove_player_id_ng":"meSqOOEM","content_injected_video_reject_by":"post-article-types","content_injected_video":false},"debug":{"content_injected_video_is_eligible":{"post_article_types":false},"sql_query_count":11},"dt:internal-links":{"injection_status":"ineligible-post-age"}};
					var allOptions = {};

					if (stage > 0 && window.DTOptions) {
						allOptions = window.DTOptions.getAll();

						Object.keys(options).forEach(function(groupK) {
							if (options[groupK] && typeof options[groupK] === 'object') {
								Object.keys(options[groupK]).forEach(function(k) {
									if (!allOptions[groupK] || typeof allOptions[groupK] !== 'object') {
										allOptions[groupK] = {};
									}

									allOptions[groupK][k] = options[groupK][k];
								});
							}
						});
					} else {
						allOptions = options;
					}

					var getAll = function () {
						return allOptions;
					};

					var get = function (key, group, def) {
						key = key || '';
						group = group || 'qnqb92BhrzmkpqGx';
						def = (typeof def !== 'undefined') ? def : null;

						if (typeof allOptions[group] !== 'undefined') {
							if (key && typeof allOptions[group][key] !== 'undefined') {
								return allOptions[group][key];
							}
						}

						return def;
					};

					var set = function (key, group, data) {
						key = key || '';
						group = group || 'qnqb92BhrzmkpqGx';
						data = data || null;

						if (key) {
							if (typeof allOptions[group] === 'undefined') {
								allOptions[group] = {};
							}

							allOptions[group][key] = data;
						}
					};

					var del = function (key, group) {
						key = key || '';
						group = group || 'qnqb92BhrzmkpqGx';

						if (typeof allOptions[group] !== 'undefined') {
							if (key && typeof allOptions[group][key] !== 'undefined') {
								allOptions[group][key] = null;
							}
						}
					};

					window.DTOptions = {
						get: get,
						getAll: getAll,
						set: set,
						del: del,
					};
				}());
			</script>
			
			<script src="https://cdn.optimizely.com/js/17571560121.js" async></script>

			<script id="dt-grid-flyer-template" type="text/template">
<div class="b-flyer b-flyer--1-4-1   b-grid__cols1  b-grid__rows4" >
	<div class="b-meta  b-flyer__meta ">
					<h3 class="b-meta__title  dt-clamp dt-clamp-3">
				<a href="<%= url %>" class="b-flyer__hot" target="">					<%= title %>				</a>			</h3>
		
		
					<div class="b-meta__text  dt-clamp dt-clamp-3">
				<%= excerpt %>			</div>
		
					<div class="b-meta__labels">
				<span><%= displayDate %></span> 			</div>
			</div>

			<div class="b-flyer__image b-flyer--1-4-1__image">
							<img src="<%= images.thumbnail %>" alt="">
			
					</div>
	</div>
</script><script id="dt-product-module-template" type="text/template">
<div class="b-product b-product--0-0 <%= (parentClass) ? parentClass + '__product' : '' %>">
	<% if (labelText) { %>
		<div class="b-product__labels">
			<% if (labelURL) { %>
				<a
					class="b-product__hot"
					href="<%= labelURL %>"
					rel="<%= labelRel %>"
					style="<%= (color) ? 'color: ' + color : '' %>"
					target="<%= labelTarget %>"
				>
			<% } else { %>
				<span style="<%= (color) ? 'color: ' + color : '' %>">
			<% } %>
				<%= labelText %>
			<% if (labelURL) { %>
				</a>
			<% } else { %>
				</span>
			<% } %>
		</div>
	<% } %>

	<div class="b-product__meta b-product--0-0__meta">
		<% if (title) { %>
			<h3 class="b-product__title">
				<% if (url) { %>
					<a
						class="b-product__hot"
						href="<%= url %>"
						rel="<%= rel %>"
						style="<%= (color) ? 'color: inherit' : '' %>"
						target="<%= target %>"
					>
				<% } %>
					<%= title %>
				<% if (url) { %>
					</a>
				<% } %>
			</h3>
		<% } %>

		<% if (text) { %>
			<div class="b-product__text">
				<%= text %>
			</div>
		<% } %>
	</div>

	<% if (buttonText && buttonURL) { %>
		<div class="b-button-wrap b-product__button-wrap b-product--0-0__button-wrap">
			<a
				class="m-aff-button"
				href="<%= buttonURL %>"
				rel="<%= buttonRel %>"
				style="<%= (color) ? 'background: ' + color : '' %>"
				target="<%= buttonTarget %>"
			>
				<%= buttonText %>
			</a>
		</div>
	<% } %>

	<% if (imageURL) { %>
		<div class="b-product__image b-product--0-0__image">
			<img src="<%= imageURL %>" alt="<%= imageAlt %>">
		</div>
	<% } %>
</div>
</script><script>(function() {var el = document.createElement('link');el.href = 'https://cdn6.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/styles/css/dt-single-foot.css?ver=1586805082364';el.id = 'dt-single-foot-style';el.media = 'all';el.rel = 'stylesheet';el.type = 'text/css';document.head.appendChild(el);}());</script><noscript><link href="https://cdn6.digitaltrends.com/wp-content/themes/digitaltrends-2018/assets/styles/css/dt-single-foot.css?ver=1586805082364" id="dt-single-foot-style" rel="stylesheet"></noscript><script type='text/javascript' src='https://cdn3.digitaltrends.com/wp-content/themes/dt-stardust/assets/scripts/js/dt-foot.min.js?ver=1586805082364' defer></script>

				<script>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</script>

					</body>
</html>
